Windows – Chrome not asking to remember passwords

google-chromepasswordswindows 7

So at one point, Chrome asks you (after login) if you want it to save the password.

The next few times I login, the dialog box/bar doesn't pop up but the key icon near the star is there.

I click it and delete some outdated or duplicate passwords.
I changed my Google password because I was forced to by Google.

Chrome isn't remembering that new password (the dialog box isn't popping up).

Is it possible to add a new password to the settings such that when I navigate to the page, the username/password is there already in the fields, highlighted in yellow? this happens in gmail. Thats when i started noticing it. (and all other sites)

Edit: This doesn't seem to happen anymore for me. although someone should answer for the benefit of other readers

Best Answer

  • From Google's help:

    Make Chrome ask to save passwords again

    If you told Chrome to never offer to save your password for a specific site, but you change your mind, you can bring back the option.

    1. On your computer, open Chrome.
    2. At the top right, click More More and then Settings.
    3. At the bottom, click Show advanced settings.
    4. Under "Passwords and forms," click Manage passwords. A box will appear with a list of saved passwords.
    5. In the "Never saved" section, select the website and click Delete Delete.
    6. Click Done. If Chrome isn't asking to save any passwords anymore, you may have asked it to stop saving passwords. Bring back the prompt by turning "Offer to save your web passwords" back on.

    Chrome isn't saving passwords If you've told Chrome to save a password but it's not showing up, try deleting and resaving it.

    1. Open your list of saved passwords, and check for the website.
    2. If the website is listed, delete the saved password.
    3. Go to the website, and sign in.
    4. To save your password, when prompted, select Save password or Yes.