Windows – Cmd always start on wrong drive

command linewindows xp

For some reason when I do Start, Run, cmd, Enter it always starts at M:, one of several mapped network drives.

I'd rather have it start on C:, or in C:\dev if possible. Is there a way I can fix this?

Best Answer

  • Create a shortcut to cmd.exe (on the desktop or in your Start menu) and right click on it, select properties. I've forgotten what it's labeled in XP, but in Windows 7 it says "Start in:" put your directory in that box.

    For a more permanent solution, you can edit the registry and change the HKEY_CURRENT_USER\Software\Microsoft\Command Processor's Autorun value. See this for details.