Windows – Configuring the xampp for WAN and LAN

lanwanwindows 7xampp

Hi and forgive me if I am unclear in this question as I am trying to get back to development after my fourth brain surgery in 2 years so I feel a little groggy.

I am trying to set (and learn how to set up) a home server with the hope of hosting my own sites in the near future. I hail from a Java background so am familiar with Tomcat and MySQL and familiar with my VPS at my hosting provider that uses Linux, Apache, Tomcat and MySQL.

In trying to replicate a similar environment on my development machine, I have opted to use and configure the latest (1.81) (.exe)Xampp. On Windows 7 (unlike my hosting provider's Linux)

I believe the following services to be installed (and configured) correctly:

  • Apache (accessed in browser) via localhost:80
  • Tomcat (accessed in browser) via localhost:8080 with the welcome Tomcat page)
  • MySQL changed the root password in xampp security menu from the xampp/index.php)

Moving on I have port forwarded port 80 on my router to refer to my local ip
And am able to access both Tomcat an Apache under my local IP and their ports.

I have also configured port 80 as an inbound port through my Windows firewall.

The last step I take is to try access my services via my WAN IP, e.g.

Right (I know I am not supposed to try access my WAN locally) I try access my WAN locally I get my routers control panel when doing so. So, I turn off wireless on my Android and use the mobile internet from my phone service provider (ensuring it's not on the LAN)and try access my WAN via Android (only the Apache service) and get the infamous timeout as the response.

I have also attempted to see if both services are accessible via but both ports fail.

Any pointers to what I could be doing wrong here?

Best Answer

Make sure all services that you need to access from the outside (e.g. Apache) are not listening on the loopback interface (, but on (all interfaces). You can see this using the netstat command (I don't have a Windows machine at hand to give you the exact command).