Windows – Ctrl + Alt + Shift + S hotkey not working in Windows 10 at all (not even in safe mode)

hotkeyskeyboard shortcutskeyboard-layoutwindows 10

I am using the Romanian (programmers) keyboard in Windows 10 so that I can insert special characters using the AltGr key (or Ctrl+Alt). All of them work EXCEPT for AltGr+Shift+S (that should insert capital S-comma or Ș). From my understanding so far, this is equivalent to Ctrl+Alt+Shift+S. My thought was that some other program had registered the combination and when I press it, it goes to that program instead.

What I have tried so far, unsuccessfully:

  • searching for hotkeys in the registry using nirsoft's RegScanner – nothing found
  • searching for hotkeys using nirsoft's HotKeyList – nothing found
  • searching for hotkeys using a vbs script from a superuser/stackoverflow post (can't remember which, I've read so many topics)
  • closing all user programs one by one with task manager and trying the hotkey to see if I closed the culprit (though this did not work as well as planned, as some services would keep restarting)
  • rebooting in safe mode did not make it work!
  • using autohotkey to insert the character – nothing happens

Basically the combination seems to be dead. I am not even sure if it registers. On Linux it works fine, and on Windows Ctrl+Alt+Shift + other characters works fine. Ctrl+Alt+S also works fine (without the Shift).

I am running out of ideas. I really thought autohotkey would work, but kept it as a last resort.
Strangely enough, autohotkey displayed the following behavior:

  • setting Ctrl+Alt+Shift+S to send the character Ș did nothing
  • setting Ctrl+Alt+Shift+S to do something else (like display a messagebox) did nothing
  • setting some other combination (like Ctrl+Alt+Shift+W) to send the character Ș would actually trigger the hotkey for Ctrl+Alt+Shift+S (so it would display the messagebox I set earlier).
  • setting some other combination to send the unicode for Ș (U+0218) would work!
  • setting Ctrl+Alt+Shift+S to send the unicode for Ș would not work

So for the moment I have it set in autohotkey with Ctrl+Alt+Shift+W since it's above the S on the keyboard, but it's less than ideal. Also, I would really want to find out the cause of this.

Best Answer

Did you try the following AutoHotKey definition?

+<^>!s::­Ș

For me, it works nicely, AltGr+Shift+S produces Ș, in line with expectations from AltGr key.

Note: Do not press Ctrl+Alt+Shift+S, it is not the same as the above. For native Windows apps, they are not equivalent.