Windows – Desktop shortcut icons all changed to Notepad icons

desktopiconswindows 7

All of my desktop shortcut icons on Windows 7 have changed to Notepad icons.

How do I get my old icons back?

Best Answer

Try this:

Reset the desktop icon cache

  1. Click Start, and open Computer.
  2. On the Tool bar, click Organize and choose Folder and Search Options.
  3. Click the View tab, and check to select the Show hidden files and folders option, and click OK.
  4. Then, enter the following directory:

C:\Users(User Name)\AppData\Local

  1. Find the IconCache.db file, and rename it as IconCache.db.old.
  2. Close the window, and restart the computer.