Windows – Folder can’t be moved here when trying to relocate Appdata\user\Local

filesystemswindowswindows 8.1

I am trying to relocate my AppData folders to free up space on my laptop's SSD drive to my much larger 1TB secondary drive.

I'm using the Location tab on the C:/Users/mark/AppData/Local to make the change and it offers to move all of the files to D:/Users/mark/AppData/Local for me.

There are a few locked files (about 6?) that I skip, and then it proceeds to make the copy, but ultimately fails with The folder can't be moved here: Failed to copy files from "C:\Users\mark\AppData\Local" to "D:\Users\mark\AppData\Local". This may be due to one or more files under the source or target folders with a fully qualified file name longer than 256 characters. The operation was cancelled by the user.

Of course, the operation wasn't cancelled by the user.

Files that were open by the system during this attempt to move:

  • UsrClass.dat
  • UsrClass.dat.LOG1
  • UsrClass.dat.LOG2
  • WebCacheLock.dat
  • WPNPRMRY.tmp
  • V01.log
  • WebCacheV01.dat
  • settings.dat
  • settings.dat.LOG1
  • settings.dat.LOG2
  • 4f37877c35670ee.dat
  • 4f37877c35470ee.dat

Best Answer

After hours and days of research, I finally happened across a helpful YouTube video that showed how it's done.

It appears that in all likelihood, just changing the path an d letting Windows copy the files over for you is going to report an error. You will end up with files that are in use.

And this causes Windows to not complete the operation, and leave the .../AppData/Local in it's original spot. It won't change the path because of the failure.

But the trick is go right back to that dialog after the original attempt with the file copy, change path to where you want it to be (in my case from C:... to D:...), and when it asks you if you want to move the files say "No". The path is now changed.

You need to reboot the system next and you should be all set.

You'll need to clean up the original location which is no longer being used. Confirm this by looking at the properties on the folder and make sure there is no "Location" tab on the original AppData/Local folder.

After this change, I also found that windows and some apps had forgotten about a few preference related things, and I had to fix things, like my Spotify shortcut, which had hard-coded paths to c:\users\mark\appdata...

Best of luck. I hope this helps some.