Windows – Google account (mail / calendar) not syncing in Windows 10

google-accountssyncwindows 10

I'm having a problem with the default Mail and Calendar apps in Windows 10. For a while I was able to sync my Google account emails (Gmail) and calendar in those apps, but about a week ago, it has stopped working: the calendar is empty (no events, and no calendars listed), and the emails that were already synced are still there, but syncing doesn't bring any new email.

I tried deleting my Google account from the mail (or calendar) app, by going to "settings -> accounts", and then re-creating the account. I did that three times. Each time I was able to complete the following steps:

  1. enter my Gmail address,
  2. then my Google account password,
  3. then the confirmation code sent by SMS,
  4. and finally got to the screen "Windows would like to…" (permissions listing), on which I clicked "Accept" (obviously).

The first time, I then got a Windows message "Something went wrong", followed by an error code (I didn't write it down).

The second time, I didn't get this error message, so it looked like the account was successfully created (it appeared in my accounts list in the settings of those apps), but nothing was synced: both apps (mail / calendar) remained empty. (I tried syncing manually by clicking the sync button in the mail app: still nothing, even though the app confirmed that it was "up to date".)

For my third attempt, I had found this question, so I went and created an "app password" in my Google account, specifically for those apps. But when I got to the password screen (step 2 described above) and entered this app password instead of my regular account password, I got an error message (from Google) asking me to enter my account password and not an app password. So I did that, and that got me exactly the same result as my second attempt (account created but nothing synced).

I also tried both answers given on the same question (first via "settings > accounts > add account > Other account", and second via "settings > accounts > add account > Advanced setup"), but none of them worked for me (again, account created but nothing synced).

Has anyone experienced the same problems? How can I make this work?

UPDATE: a few months back (early October 2015) I received an email from Microsoft inviting me to "reconnect to Google" (that was the title of the email). I ignored it for a while, but recently followed the steps in this email and now everything seems to be working fine. So I'm guessing that MS somehow fixed whatever bug it was.

Best Answer

  • That might have caused due to this privacy setting turned off. Go to settings > Privacy > Calender and turn on the settings “Let apps access my calender“. Also the other two settings. Try syncing the mail app. That should work.

    Source: http://www.alltechflix.com/windows-10-mail-app-not-syncing-fix/

  • Related Question