Windows – How to connect the XP laptop to the wireless network if the wireless network doesn’t show up in the list

internetrouterwindows xpwireless-networking

The Problem

For some reason my XP laptop can not see my wireless network but my Vista laptop can see it fine. I should also say that my XP laptop can see all my neighbors' wireless networks just fine.

My Questions

  • How come my XP laptop does not see my wireless connection?
  • Do I have to manually add my wireless network to the list?
  • If so, why? Why can it see all my neighbor's wireless networks but mine?
  • How can I connect my XP to my wireless network?

UPDATE
I thought it would be a good idea to post more details about my setup:

Router: Wireless
Basic Settings

  • brand: Techniclan

  • model: WAR-54G

  • band: 2.4 GHz (B+G)

  • mode: AP
  • SSID: Rilos
  • Channel Number: 13

Advanced Settings

  • Authentication type: Auto Select
  • Data Rate: Auto
  • Preamble Type: Long Preamble
  • Broadcast SSID: Enabled
  • IAPP: Enabled
  • 802.11g Protection: Enabled
  • RF Power: 20dBm

Security

  • Encryption: WPA2
  • WPA Authentication Mode: Personal (Pre-Shared Key)
  • WPA2 Cipher Suite: AES

Access Control

  • Wireless Access Control Mode: Disable

Router: WAN Interface

WAN Interface Setup

  • WAN Access Type: DHCP Client
  • Attain DNS Automatically
  • MTU Size: 1492

Router: Management

Operation Mode

Selected Operation Mode

  • Gateway

    In this mode, the device is supposed
    to connect to internet via ADSL/Cable
    Modem. The NAT is enabled and PCs in
    LAN ports share the same IP to ISP
    through WAN port. The connection type
    can be setup in WAN page by using
    PPPOE, DHCP client, PPTP client or
    static IP.static IP.

Other unselected operation modes are:

  • Bridgeclient, PPTP client or static IP.

    In this mode, all ethernet ports and
    wireless interface are bridged
    together and NAT function is disabled.
    All the WAN related function and
    firewall are not supported.

  • Wireless ISP

    In this mode, all ethernet ports are
    bridged together and the wireless
    client will connect to ISP access
    point. The NAT is enabled and PCs in
    ethernet ports share the same IP to
    ISP through wireless LAN. You must set
    the wireless to client mode first and
    connect to the ISP AP in Site-Survey
    page. The connection type can be setup
    in WAN page by using PPPOE, DHCP
    client, PPTP client or static IP.

Manually Added Wireless Network: Rilos
I access this information by going:

Control Panel > Network Connection > double clicking 'Wireless Network Connection' > in the section called 'Related Tasks' (left hand column, 2nd section) click 'Change advanced settings' > Wireless Network Connection Properties with 3 tabs: General, Wireless Networks and Advanced

General tab

  • Connect using: acer IPN2220 Wireless Lan Card
  • This connection uses the following items:
    • Client for Microsoft Networks: Checked
    • Intel Wireless Connection Agent: Unchecked
    • File and Printer Sharing for Microsoft Networks: Checked
    • QoS Packet Scheduler: Checked
    • AEGIS Protocol (IEEE 802.1x) v3.1.0.1: Checked
    • Internet Protocol(TCP/IP): Checked

Also I have:

  • Show icon in notification area when connected: Checked
  • Notify me when this connection has limited or no connectivity: Checked

Wireless Networks tab

The box 'Use Windows to configure my wireless networks' is checked.

In the 'Preferred Networks' section there is one network named Rilos (Automatic) I click it to select it then click 'Properties' and 'Rilos Properties' window pops up.

In the Association tab I have:

  • Network name(SSID): Rilos
    NOTE: The name Rilos in the text field is grayed out. Can't click into it to change it.

In the 'Wireless network key' section I have:

  • Network Authentication: WPA-PSK
  • Data Encryption: AES
  • Network key: I types my router's password/passphrase into it.

In the Authentication tab everything in there is grayed out and inaccessible.

Connection tab

  • 'Connect when this network is in range' selected.

Thanks,
Adam

Best Answer

You say that the laptop is Windows XP, this can be up to/around 10 years old.

My guess would be that the wireless network is being broadcast in a band or mode (a/b/g/n) that the wireless card in your laptop does not understand.

If however it does understand, my best bet and advised solution would be to manually assign/setup the profile and see if it will connect as sometimes this can work.

Go to the list of preferred networks (Network connections, right click wireless, go to the wireless networks tab), and type the details.