Windows – How to get MY Documents folder back under “This PC” in explorer view tree

windows 10windows-explorer

Got this new computer with win 10 pro … love it, save for one MAJOR issue. For some reason, it ONLY shows the "Onedrive" documents folder under this PC. For a minute, it had the "multiply" issue, which i've since fixed. And I don't want to "not use" onedrive, i like it. But I can't get to "my documents" anymore without having put it in "Quick Access" tree. Everytime I click on "Documents" under "This PC" it always goes straight to the folder in Onedrive, which i hate. I even tried deleting that folder in Onedrive, but it just remade itself and still is the only Documents link under This PC. It doesn't make since, all otehr shortcuts (Pictures, Music, Video) all go to the %UserProfile% location, but the local Documents folder would be completely lost if not for a shortcut I put under Quick Access. This is extremely frustrating! Please help!

enter image description here

Best Answer

Right-click the OneDrive icon in the Notification area and click Settings. Click the Auto save tab. In Documents and Pictures, select This PC only for both Documents and Pictures. (REF: Files save to OneDrive in Windows 10)

If that doesn't help, you may have to reset the shell folder paths in the registry, as in Windows 10 User Shell Folders Restore Default Paths. (You need the registry fix #3, or refer to Table #2 for editing manually.)