Windows icon cache does not exist

cacheiconswindowswindows 7

I've just performed a fresh install of Windows 7 Home Premium 64bit, and have installed all updates and SP1. After installing IObit Smart Defrag, I noticed the icon for that software was the generic application icon in Windows, rather than that of the actual software. So naturally, I assumed I need to rebuild the icon cache, as is widely explained all over, and I've done it a million times.

However, when I navigate to C:\Users\[Username]\AppData\Local\, There is no file IconCache.db. I have restarted and this file still does not exist. Obviously I replaced [Username] with the actual username, and have selected to show hidden/system files. I've even tried a command prompt, and that too reports that the file does not exist when I tried deleting it from there. So this file really isn't there.

What is wrong and how do I fix this? It seems this new Windows install has no icon cache at all, and I am seeing random other applications showing the same generic icon…

EDIT

Adding to the confusion… These applications which are showing the generic Windows icons indeed do have a proper icon. I right-click the EXE and go to Properties, and it has the correct icon displayed there. However, across Windows Explorer, including the Taskbar, these application icons are not showing. And that cache file does not exist.

EDIT

I've done a trial… I created a new user account on this system (Administrator) as this cache is on a per-user basis. Unfortunately this new user also has no icon cache. It's not that I just can't see the file – the file really isn't there, no matter what method I try to delete it (Windows Explorer, Command Prompt, even my own custom code).

EDIT

As suggested in comments in an answer, I checked the registry under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\ to only discover everything is missing from here. The only key here is Directory, whereas another normal install has hundreds of file extensions listed here.

enter image description here

Best Answer

Some files will not show even if you show hidden.

To make sure you delete the icon cache, do this:

  1. Open task manager.
  2. In the Processes tab, click on explorer.exe and click End Process. You then get a confirmation dialog. Click "End Process" to confirm.
  3. From the File menu (don't close task manager yet), choose New Task (Run...).
  4. Run a command prompt (cmd).
  5. In there, paste del %userprofile%\AppData\Local\IconCache.db /a
  6. The the command prompt window, then type explorer.exe to reload the explorer and the UI
  7. Check now, your icons should be fixed.