Windows ignores GPT disk and converts to MBR during installation

gpthard drivembrpartitioningwindows 7

I have followed these steps to install windows 7 home premium x64 on a 3tb drive (asus z87-z motherboard):

Windows Setup: Installing using the MBR (Master boot record) or GPT (GUID Partition Table) partition style

In the console window, diskpart, I ran:

select disk <disk number>
clean
convert gpt

Then when using the GUI to partition the disk to install windows, it always reverts back to MBR (list disk shows no asterisk under gpt).

I tried again, in this case cleaning and converting the disk, then pointing windows at the partitioned disk and letting it install.

By going to Control PanelAdministrative toolsComputer ManagmentStorageDisk Managementand checking the properties of the disk I can see that it is now a MBR.

Is there something I have missed? Could there be something in my setup incompatible with GPT that is causing this?

Best Answer

When your computer turns on, press the appropriate F# key on to enter your system's BIOS/EFI. In there look for a mode setting that allows you to choose between booting in CSM (Legacy), or EFI, choose EFI mode.

Save your changes, exit the BIOS/EFI, and boot up the Windows installation disc. You should now be able to format the disk as GPT, and install to it.