Windows – keep Windows from defaulting printers to A4 paper

input-languageslocalepaperwindows

There's an old joke that English will be the language of Heaven, because Americans won't learn foreign languages. Microsoft seems to have internalized this joke…

I am an American English speaker; I occasionally need to type in Russian, so I install the Russian Phonetic Student (aka "yasherty") keyboard and occasionally switch to it. As soon as I install it, all of my printers default to A4 paper instead of Letter. Since the two sizes are pretty close, it's usually not a problem – but labels (actually, anything with narrow margins) don't work properly, and various documents insist on being loaded into the manual-feed tray of whatever printer I happen to be using. (It took me a while to understand why that was happening – that was how I initially discovered that my paper size had changed.)

I can go to Properties for each installed printer, and in Preferences – Paper/Quality – Advanced I can set the Paper Size for each tray the printer supports. That fixes the problem. However, if I install another printer – or if PDFCreator updates itself – I have to do it again.

This happens in Windows XP, Vista, 7, and 8 (I never installed an alternate keyboard before XP); it happens with the Russian Phonetic, Russian Standard, Russian Typewriter, and various French keyboard layouts. My Region and/or Locale settings (depending on the Windows version) have always been United States/English – but as soon as I indicate that I might speak another language, Windows apparently decides I'm European, and sets my paper size accordingly.

Best Answer

I do not know if this will solve your issue after keyboard changes. But I've been having to change printer properties every time I print, from A4 defaults, and finally think I have fixed it.

To change the printer defaults, you have to be in Control Panel, Devices and Printers. Right click and select -->Printing Preferences. Adjust the Paper size to Letter, then click the button -->Default. Click apply. The settings on the default printer seem to now have picked up on the other printers (Windows 10.)

(As a matter of reference, I am in Canada, not Europe, and A4 keeps showing up)