Windows – Map drive over VPN (cmd works fine on regular network)

vpnwindows-networking

I need to map a network drive over VPN.

Very simple host network: no Microsoft server, no AD. Just one router and a NAS appliance (simple Linux file server).

When at the office, I can map a drive letter as follows:

net use f: \\192.168.1.3\MyShare /User:MYSELF mypass

However, when try same command over VPN, I receive the response:

System error 1244 has occurred.
The operation being requested was not performed because the user
has not been authenticated.

ADDITIONAL INFORMATION:

Two identical Cisco WRVS4400N VPN routers create the VPN. Router1 in office (192.168.1.1), Router2 in soho (192.168.11.1). VPN works perfectly, no client software required. When at SOHO (behind router2 with an IP address of 192.168.11.100), can successfully ping 192.168.1.3.

Routers have latest firmware.

Over VPN I cannot browse network via Windows Explorer (Win7 Network Neighborhood shows only my PC as opposed to several PCs and the NAS box "NAS01" when in the office).

Over VPN, I cannot connect by entering \\192.168.1.3\MyShare into Windows
Explorer's address bar (although I can do that successfully when at 
the office).

Over VPN, I am able to view the NAS administration screens via
https://192.168.1.3/admin and I can print to the office TCPIP printer
(192.168.1.222) -- both non-routable IPs.

ADDITIONAL EDIT:

Thanks for the important hints and clues as to where to look for the problem.

Windows 7 Home Premium, which is on my laptop, exhibits this behavior.

A different laptop, installed with Windows7 Professional, works fine.

Is it likely that Win7 Home vs. Win7 Pro is the problem? If so, is there any way to overcome this limitation without upgrading to Pro? (i.e. Registry changes, configuration settings, copy over certain files from Pro to Home, etc.)

Best Answer

If the NAS has some sort of "restrict to local network" option, that might be worth looking into. Otherwise, there's a possibility that there's some sort of firewalling happening on the VPN link. And finally, as everyone has noted, make sure you're authenticating as a user that exists on the NAS. You may need to specify NASHOST\nasusername rather than just nasusername.