Windows – NSLookup not working (Win10)

dnsnetworkingnslookupwindows 10

I'm currently having problems accessing one of my clients servers and it seems that there is probably a problem with the network connection between myself and the server. However one of the things I've tried is to get the actual IP address of the server via the nslookup windows command line tool. However this does not seem to work on my computer.
Running any nslookup command simply returns 'No response from server'.

Here is an example:

C:\Windows\system32>nslookup www.google.com
Server:  UnKnown
Address:  2606:4700:4700::1111

*** UnKnown can't find www.google.com: No response from server

In this particular example I've set up my DNS to use Cloudflare DNS but the same problem occurs if I use my provider DNS or Google DNS.
I have no problem accessing the google servers and working with the internet so obviously DNS works. Does anybody have any idea why nslookup does not work?

Here is my ipconfig /all output:

C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Wildfire
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GbE Family Controller
   Physical Address. . . . . . . . . : 9C-5A-44-3C-4D-9E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 1:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : 48-F1-7F-C2-ED-9B
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 10:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 4A-F1-7F-C2-ED-9A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Killer(R) Wireless-AC 1550i Wireless Network Adapter (9560NGW) 160MHz
   Physical Address. . . . . . . . . : 48-F1-7F-C2-ED-9A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::30b6:eeab:4d53:b8e4%9(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.107(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 21. listopada 2019. 9:09:22
   Lease Expires . . . . . . . . . . : 21. listopada 2019. 11:09:21
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 105443711
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-ED-51-AC-9C-5A-44-3C-4D-9E
   DNS Servers . . . . . . . . . . . : 2606:4700:4700::1111
                                       2606:4700:4700::1001
                                       1.1.1.1
                                       1.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : 48-F1-7F-C2-ED-9E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter vEthernet (Default Switch):

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
   Physical Address. . . . . . . . . : 00-15-5D-F7-39-02
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::fd51:db6:50fd:5d6b%23(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.46.225(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.240
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 385881437
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-24-ED-51-AC-9C-5A-44-3C-4D-9E
   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

C:\Windows\system32>

Best Answer

You have IPv6 addresses of (CloudFlare's) DNS servers configured... but you don't actually have an IPv6 address of your own – your Internet access is IPv4-only.

(Many programs will automatically retry with a different DNS server if the first one is unreachable, but apparently nslookup does not – it'll always be trying the 1st server in the list.)

Open the IPv6 configuration window (e.g. through ncpa.cpl) and set "DNS servers" to "Automatic".

Related Question