Windows – Prevent Network Printers Automatically being added to ‘Devices and Printers’ in Windows 7

network-printernetworkingprinterwindows 7

I think my question is a duplicate of this one, but the original question was never properly answered (the steps described are for Windows XP).

I am aware of the option to "Turn off Network Discovery" (under Control Panel > All Control Panel Items > Network and Sharing Center > Advanced sharing settings); I set this option (for both Home/Work and Private) but it doesn't seem to stop the printers getting added, and has the side effect of preventing me from browsing the list of machines on the network (which I need).

I've tried the Windows XP registry option – but it doesn't seem to make any difference:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\NoNetCrawling

I find it annoying having the printer list cluttered with printers from all over the office which I am never going to use (especially since lots of them no longer physically exist, users just haven't deleted them from their machines). This must be a real problem for people in massive offices with large numbers of printers – but I can't seem to find a lot of people complaining about it – which makes me think I'm missing something obvious.

I don't really want to hack the firewall or turn off sharing completely, I still want to select and use network printers and file shares.

Any ideas?

Best Answer

Try going to:

Control Panel (icon view)> Network and Sharing Center > Change advanced sharing settings (on left side of screen)

Under: Private > Network discovery

There is a box that says "Turn on automatic setup of network connected devices."

Uncheck that box and click "Save changes."

These instructions are for Windows 10, but they are probably similar for 7 and 8. I checked my Vista PC and I do not have this option. However, I never had printers auto install (software & EVERYTHING) with my Vista PC. I hope this helps.