Windows – Prevent Windows from resetting date format settings on restart

regional settingswindowswindows 8.1

My Windows 8.1 machine has its region set to English (United States). The default date format is dd/MM/yyyy, but I modify the date format to a different setting. In this case, dd-MMM-yyyy.

enter image description here

It seems that on every reboot, the date format reverts back to the default format of dd/MM/yyyy.

How can I prevent the date format from reverting to the default?

  • this machine is on a domain, and it is subject to Group Policies set by domain admins. I cannot determine if these is a GP being pushed to the machine.
  • my account is in the local Administrators, and can set GP settings if needed
  • reboots typically happen after monthly Windows updates

Best Answer

"this machine is on a domain, and it subject to Group Policies set by admins." Well there's your most likely answer. Have you checked to see if GP is actually applying a time setting?

Assuming as much, then you need to discuss with the Network/Group Policy admin about getting yours changed properly.

I say this because even as a local admin. domain GPs outrank you, and will change your settings regardless of what you do.

That is short of you denying domain admin (etc.) permissions to your registry; which is a good way to get in trouble since it's not your computer. And since it's not your computer, you're at the mercy of the people in charge, so go talk to them. :)