Windows – Remote desktop is not working – no port 3389 is bound

networkingremote desktopwindows 7

On a Windows7 Pro the remote desktop stopped beeing available.

This is what I checked:

  • Port 3389 is not available from extern (telnet .... 3389 does not work but telnet .... 445 works)
  • netstat shows that there is no prozess listening at port 3389
  • "Remote Settings" is configured with Allow connections from computers running any version of Remote Desktop ...
  • the services (Remote Desktop Services, Remote Desktop Configuration and Remote Desktop Services UserMode Port Redirector are running)
  • The service Cryptographic Services is also started
  • windows firewall is disabled
  • no third party firewall is installed
  • In the registry is port 3389 configured at ..\Control\TerminalServer\WinStations\RDP-Tcp
  • resetted the ip stack but without success

The customer says that it was working in the past.

In the netstat log (netstat -abn) isn't any entry like

TCP               LISTENING

and telnet

telnet 3389

does not connect from the localhost and from a remote host in the same network, although the firewall is disabled and other ports (like 445) do listen and do answer.

Found a similar thread here and the suggestion it may be caused by: KB2830477. Didn't help.

Best Answer

To know on which port RDP service is listening, check on following registry path:


How to know/change default RDP listening port

Make sure there are restiction of port on your local physical network devices(routers,firewall).

Related Question