Windows – The process “ati2evxx.exe” clogs half the RAM, how can I disable it

display-drivermemoryprocesswindows

I have a Windows XP 32-bit OS on my computer, which has been acting strange lately: the system REFUSES to shut down, standby or even hibernate. Sometimes, the system even randomly reboots with a split second blue screen. Luckily, I found the cause of the problem: one process uses so much RAM, it leaks into system processes.

I have an HIS Radeon 6670 graphics card, and all the latest drivers for it. However, the process "ati2evxx.exe" is using 743M of my 3GB of RAM. Now I understand there is a restriction to how much ram a process can have, especially in 32-bit systems, but Windows XP should have a relatively tiny system footprint.

Is there a way I can disable this process? I looked it up and all I saw was that it was a hotkey poller. (why would an event listener take up so many resources??!) Any help is appreciated.

Best Answer

Click the Start button, select Run and type in: msconfig

Click the Services tab and uncheck the Ati HotKey Poller service and click Apply and then OK

You will be prompted to reboot. This should resolve the issue.

Source: I had the same windows XP, same graphics card and the same problem. This silly little hotkey polling service should consume kilobytes of memory but on my system was consuming 1.2 gigabytes! It has severely damaged my opinion of the programming abilities of ATI and the quality of the software.