Windows – Why is the library/Documents shortcut showing all files from all subfolders in one flat list

windows 7windows-explorer

I am using Windows Explorer on Windows 7.
In My Documents there's a folder 02 KOOP. If I go there using the adress bar:
D:\users\username\My Documents\02 KOOP
I get a view of my subfolders and some files:

enter image description here

However when I use the Documents shortcut under Libraries, and then go to the 02 KOOP folder, all files that are located in all subfolders are listed in one big list. When you view the file properties, the actual location is shown:

enter image description here

This is the only subfolder of My Documents that has this behaviour.

Did I accidentally change some setting, or is something wrong?

Is this some setting I accidentally changed?

Best Answer

I had the same problem and this fixed it. Right-click on "Documents" and make sure the library is optimized for "General Items" NOT "Documents". If you select "Documents" it doesn't show any subfolders.