Windows XP requires BIOS IDE setting to boot up, how to fix this

bootruntime errorwindowswindows xp

Every time I try to boot my system which runs on windows XP, my PC does not start and I have to press F10 to go to BIOS set up mode and under advanced option, I have to select IDE (in default mode, it shows RAID), and after saving it by pressing F10, the PC boots up. How do I resolve this problem?

Further, It seems my CMOS battery is dying as my PC does not show correct date and time recently.

Best Answer

  • As @Gaurav Joseph already wrote, the problem is caused by the BIOS battery.

    Some background:

    In order to access a disk you need the right drivers. In the past those drivers were loaded before you could start installing.

    Eventually the disk controllers and disks in most PC type computers standardised to something called IDE or ATA. Windows XP (and other operating systems) took advantage of this and added the most common drivers to their OS. If you used something to new or something unanticipated (e.g. a RAID card, many SCSI drivers, …) then you still need to load the drivers for that.

    This could be done after installing the OS on a supported disk, or by pressing F6 and inserting the floppy with the drivers during installation of XP.

    Yes, floppy. Old. :)

    Back to your computer:

    Your computer seems to have a SATA controller and a SATA disk. This is not the same as the classic ATA (also called PATA). You need additional drivers to use that. Drivers which are not on the XP installation CD.

    Since this was annoying to most people many computers got shipped with an option to use SATA devices in a legacy (IDE compatible) mode.

    All of this means that:

    1. You could set the BIOS to AHCI (that is the normal SATA mode) and install XP with extra drivers.
    2. Or you could set the BIOS to ancient legacy mode and just install XP without bothering with extra drivers.

    The person which installed your computer has done the last. This is why your XP will not boot unless the BIOS is set to configure the disk controller in legacy mode.

    BIOS.

    I Just wrote that in your case the BIOS must be set to legacy mode. The BIOS needs to remember this. It does that by writing this information to a chip which need electricity to keep that information. Either by having the computer turned on, or from a backup battery when the power is turned off.

    If this backup battery is empty then the BIOS will loose its stored configuration when you turn the computer off. Usually this means it will return to its defaults.

    In your BIOS you will find three options for the SATA controller:

    1. AHCI
    2. Legacy / IDE
    3. RAID.

    It appears that the last option is the default. And just like any non-legacy mode XP requires drivers for this.

    That means you have two solutions:

    1. Proper solution: Replace the backup battery (and thus keep all BIOS settings intact when the PC is off.)
    2. Add the drivers to the OS allowing it to boot with the default settings.

    The latter is not trivial on a boot disk with XP.

  • Related Question