Excel – Word 2010 – Mail Merge with Superscript Formatting

mail-mergemicrosoft excelmicrosoft wordmicrosoft-office

I have a user with a letter in Word 2010, built for a mail merge. The source document for the addresses is another Word document. The source document includes addresses that have super-scripted street names. (ie. 77 1st Avenue)

When we do the merge, the formatting is lost. (ie. 77 1st Avenue) The formatting was preserved in Office 2003 without an issue. The same loss of formatting occurs when Excel 2010 is used as the source document.

Is there a switch that needs to be set? In the field properties, I selected "Preserve formatting during updates", but no luck.

Update: I found an article on Microsoft's support site, discussing a similar loss of formatting during mail merges.

http://support.microsoft.com/kb/320473

It suggests using Dynamic Data Exchange. Unfortunately, I could not get a link to work with an Excel 2010 document. I was able to link from Word 2010 to an older XLS document, but still, the formatting was lost.

Best Answer

One of the in house techs figured out a way to make it work. The source document ended up being a Word 2010 document.

When setting up the mail merge, use Alt + F9 to reveal the Mail Merge codes. The address field will look something like this.

{ MERGEFIELD Address }

Change "MERGEFIELD" to "REF".

{ REF Address }

Use Alt + F9 again to go back to the original style of Mail Merge codes.

Now, if you "Preview Results", the formatting carries over. It works with superscripts, bolded words, etc.

Note that it's kind of deceiving in that if you press Alt + F9 again to switch back to the other style of Mail Merge codes, you see "Error! Reference source not found." messages. Just ignore those. "Preview Results" still shows the proper output.