Word automatically switches to Times New Roman whenever I type using a German keyboard layout

fontsmicrosoft wordmicrosoft-word-2016

No matter what I do, as soon as I type anything in any word document, the font will switch to Times New Roman.

I can select existing text, chose any font and it will change to that font. But as soon as I type something, that newly typed text will again be in Times New Roman. (Existing text remains unaffected, I can type right in the middle of a word and the new letters will be Times New Roman, while the letters before and after remain whater font was selected before.)

And the problem goes away when I switch to an English keyboard layout. This is not a solution of course, but might help in narrowing down the issue.

The paragraph style I have selected is Normal and the font for this style is Calibri (Body).

Here is a video of the problem:

https://www.youtube.com/watch?v=GbprDlAb_Oo

I have completely uninstalled and reinstalled Office, to no avail.

I tried searching online, but I could only find plenty of people who are asking how to configure a default font or how to change fonts, but nothing related to my problem. It might be buried somewhere under all the unrelated search results, though.

Windows 10 Pro

  • Version: 1809
  • Build: 17763.55

Microsoft Office 365

  • Word Version: 1811
  • Build: 11029.20079 (Monthy Channel)

I have had this problem for a while now (the video is of an older build (1804 / 9226.2114)) I am actually not sure when it first occurred, as I use Word only a few times a year.

This question seems somewhat relevant, as I am using a German keyboard layout on an English OS and English Office, but it's about Word 2011 on Mac. The "Match font with keyboard" option mentioned in this answer doesn't seem to exist in my version of Word.

This question describes the same problem, however unlike the OP in that question, my "Normal" template does not contain (Intl) Times New Roman under Font. Instead it simply looks like this:

Font: (Default) +Body (Calibri), Left
Line spacing: Multiple 1,08 li, Space
After: 8 pt, Widow/Orphan control, Style: Show in the Styles gallery

Some further information that might help narrow down this problem:

1) File > Options > Add-ins > "COM Add-ins":
Screenshot of COM-Addins window, showing one COM Add-in, Visual Studio Tools for Office Design-Time Adaptor for Word
– One Add-in: Visual Studio Tools for Office Design-Time Adaptor for Word

(2) File > Options > Add-ins > "Templates":
Screenshot of Templates window, showing empty full path and checkbox marked for "Automatically update document styles"
– Full path is empty.
– "Automatically update document styles" is unchecked.

(3) I don't think that I have any VBA macros, but I

(4) This happens both with .doc and .docx.

(5) In File > Options > Proofing > AutoCorrect Options:
– AutoFormat As You Type > "Def‌ine styles based on your formatting" is unchecked.
– Preserve > Styles is checked.

Best Answer

  • This is an obscure bug that affects Windows 10 when the language is set to "English (German)" with a German keyboard layout.

    The solution is in Settings to set the language to pure "English (US)", then add the German keyboard layout.

    The reports I have found were specifically for that combination of language and the German keyboard, but this bug might possibly happen with other languages. I can only theorize that it relates to some mishandling in Word of such a language/keyboard combination.