Word – Port forward localhost using Xampp

apache-http-serverforwardingportWordpressxampp

I have built a wordpress site on my localhost:8081 .
Now i would like to access it from the internet(please dont suggest ngrok etc etc). I have a netgear wgr614 router. Now this is what i have done:
1. Logged in my router,went to port forwarding,added a new service with port 8081 start and end ports,and forwarded it to my local ip address (i know i am using dhcp,it will reserve a static address later)
2. Went to windows firewall,added rules for inbound and outbound connections to allow all from port 8081 3. Did that same stuff to my mcafee firewall

Now when i type my global ip:8081….i get problem loading page. Please can anyone suggest where i may be mistaken….or i need to do something else also. Thanks .

Best Answer

To troubleshoot I would do the following

  1. Turn off windows firewall completely
  2. Turn off mcafee firewall completely
  3. Test again

If it fails be sure you have a static ip address (usually you have to pay your ISP for one)

Else:

You could use free dns services like:

  1. Free domain
  2. noip.com
  3. dyndns.com