Linux – Xephyr keyboard layout

keyboard-layoutlinuxxephyr

For some reason Xephyr interprets the Alt Gr key as Return. Therefore I cannot enter special characters that need Alt Gr. Also other non alphanumerical keys seem to be messed up.

I start Xephyr with this command:

Xephyr :1.0 -query localhost -host-cursor -screen 1280x960 -keybd ephyr,,,xkbmodel=evdev,xkblayout=de

I couldn't find an explanation of the -keybd option. The values I use I guessed from an example I found somewhere in the web.

I have a Microsoft Comfort Curve Keyboard 2000 v1.0 and use Fedora Linux 14 x86_64 with KDE.

Best Answer

  • I have also spent some time trying to figure out those options. I have succeeded configuring it properly with the help of the setxkbmap tool and some guessing:

    $ setxkbmap -query  
    rules:      evdev  
    model:      pc105  
    layout:     de  
    options:    grp:alts_toggle  
    $ Xephyr -keybd ephyr,,,xkbmodel=pc105,xkblayout=de,xkbrules=evdev,xkboption=grp:alts_toogle -ac -reset -screen 1672x1022 -retro :50 &
    

    The man setxkbmap page also provides a hint about where to find more configurations:

    /usr/share/X11/xkb

    Take a look into this directory, specially into this file, if using xorg:

    /usr/share/X11/xkb/rules/xorg.lst

  • Related Question