Eclipse Gradle Plugin ‘could not fetch model of type’

eclipsegradlegradle-eclipse

I am running Eclipse Luna on OS X with Gradle IDE 3.6.1 and anytime I try to select a project from the gradle tasks panel I get the following error:

org.eclipse.osgi.internal.framework.EquinoxConfiguration$1
Could not fetch model of type 'EclipseProject' using Gradle distribution 
'https://services.gradle.org/distributions/gradle-2.0-bin.zip'.

Has anyone else run into this error? I can get to the URL specified to download the file myself. So, network connectivity shouldn't be the problem.

Best Answer

The problem is for the java version configured by default on the IDE (Eclipse or Spring Tool Suite). The error is the following:

enter image description here

To fix it, you can set the Java version supported by the Gradle version in Configure Workspace Setting option.

enter image description here

enter image description here

Finally, you can refresh your project o continue with your creation. Later all will be perfect.

enter image description here