Ubuntu – ASUS Q551LN on 16.04 with Intel AC7260 wireless Rev 2

driversintel-wirelesswireless

On this system, the airplane mode indicator is always on. fn+f2 does nothing.

The light under the key stays on.

Toggling airplane mode to "ON" in settings DOES turn the light off and disables wifi.

dmesg | grep iwl reveals that the… well, see for yourself.

[    2.388908] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
[    2.412003] iwlwifi 0000:03:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[    2.499087] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    2.499661] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    2.500164] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    2.743706] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    2.745332] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[    3.050151] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    3.050657] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    3.258637] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[    3.259261] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2284.915212] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.076626] iwlwifi 0000:03:00.0: uCode file size 36723 does not match expected size
[ 2285.077033] iwlwifi 0000:03:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[ 2285.093315] iwlwifi 0000:03:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[ 2285.093640] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.094141] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.311986] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[ 2285.313993] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[ 2285.337842] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.338348] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.544302] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
[ 2285.545053] iwlwifi 0000:03:00.0: L1 Enabled - LTR Enabled
e

Similar posts have been found. but, related to 12.04, not 16.04. And, no solutions were offered anyway.

I suspect that this may be related to another problem with always running hot and on "battery" when AC is attached. But, honestly, I am completely lost.

Any help would be appreciated.

Thank you.

Best Answer

  • loaded firmware version 16.242414.0 op_mode iwlmvm

    uCode file size 36723 does not match expected size

    You are loading defective -16 firmware. Why don't we simply download the -17 firmware which is newer and, in my experience, better? From the terminal:

    wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.161_all.deb
    sudo dpkg -i linux*.deb
    

    Reboot and test.

    You might see if the F2 light, an LED actually, performs correctly after this:

    sudo -i
    echo "options iwlwifi led_mode=1"  >>  /etc/modprobe.d/iwlwifi.conf
    exit
    

    Reboot and test.

  • Related Question