Ubuntu – Can someone tell me what this means and how do i fix it?

aptdependenciesffmpegpackage-managementvlc

All i wanted to do was put vlc on my computer. This is turning into a real pain in the butt. I had to update and upgrade just to get the software centre to run, but when i try to install vlc i get the following. when i try to install anything actually i get the package dependency error message…. here is my deal, this is a brand new computer, straight out of the box, ubuntu is not at all user friendly and when i ask people for help they want to try to show how smart they are by talking computer geek language. if the system had better help from people then maybe we wouldnt all be wishing it was windows easy. please help me with this, and please speak in a language that a novice beginner ubuntu user can understand. thanks in advance guys.

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
       Depends: libavcodec53 (>= 4:0.8-1~) but it is not going to be installed or
                libavcodec-extra-53 (>= 4:0.8-1~) but it is not going to be installed
       Depends: libva-x11-1 (> 1.0.15~) but it is not installable
       Depends: libva1 (> 1.0.15~) but it is not installable
       Recommends: vlc-plugin-notify (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

THEN;
i tried to use the movie player that came with ubuntu and it said that it had to search for codecs or something, it searched found what it needed to play the movie i hit install button and it came up with this error;

gstreamer0.10-ffmpeg: Depends: libavcodec-extra-53 (>= 4:0.7.3-1) but 4:0.8.6ubuntu0.12.04.1 is to be installed
                      Depends: libavformat-extra-53 (>= 4:0.7.3-1) but 4:0.8.6ubuntu0.12.04.1 is to be installed
                      Depends: libavutil-extra-51 (>= 4:0.7.3-1) but 4:0.8.6ubuntu0.12.04.1 is to be installed
                      Depends: libc6 (>= 2.7) but 2.15-0ubuntu10.4 is to be installed
                      Depends: libglib2.0-0 (>= 2.31.2) but 2.32.3-0ubuntu1 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu0.1 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.31) but 0.10.36-1ubuntu1 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.16) but 1:0.4.16-1ubuntu2 is to be installed
                      Depends: libpostproc-extra-52 (>= 4:0.7.3-1) but 4:0.8.6ubuntu0.12.04.1 is to be installed
                      Depends: libswscale-extra-2 (>= 4:0.7.3-1) but 4:0.8.6ubuntu0.12.04.1 is to be installed

I use my computer for two things, watching movies and writing in libre office. im getting a lot of writing done which is good but only because i cant watch anything. please once again help me, thank you. denny

UPDATE:

Tried to install Synaptic, got this:

dennis@dennis-X201EP:~$ sudo apt-get install synaptic
[sudo] password for dennis: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 synaptic : Depends: libept1.4.12 but it is not installable
            Recommends: rarian-compat but it is not installable
E: Unable to correct problems, you have held broken packages.

Tried to install VLC again and got this:

dennis@dennis-X201EP:~$ sudo apt-get install vlc
[sudo] password for dennis: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
       Depends: libavcodec53 (>= 4:0.8-1~) but it is not going to be installed or
                libavcodec-extra-53 (>= 4:0.8-1~) but it is not going to be installed
       Depends: libva-x11-1 (> 1.0.15~) but it is not installable
       Depends: libva1 (> 1.0.15~) but it is not installable
       Recommends: vlc-plugin-notify (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
       Recommends: vlc-plugin-pulse (= 2.0.8+git20130825+r612-0~r43~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Thanks for the help though, (and for the edit Mr. Castro).

Best Answer

It seems that updating/upgrading your system has installed packages which are not compatible for VLC

You can fix this issue by completly removing VLC:

  • Execute following commands in terminal:

    $ sudo apt-get --purge remove vlc*
    $ sudo apt-get autoremove vlc*
    
  • Fix broken packages:

    $ sudo apt-get autoremove
    $ sudo apt-get --purge remove
    $ sudo apt-get autoclean
    $ sudo apt-get clean
    $ sudo apt-get -f install
    
  • Install VLC again:

    $ sudo apt-get update
    $ sudo apt-get install vlc
    

Synaptic package manager is a great tool to fix such issues. You can forcefully install such files by search it there:

  • Fist install synaptic package manager if you don't have already installed:

    $ sudo apt-get install synaptic
    
  • Then open synaptic package manager -> click Custom Filters down-left -> click Broken top-left, it will list all broken packages try to all broken packages. Also if any residual packages are there on more option you will get as residual packages.

  • To install forcefully:

    Search for missing pacakge-> hightlight it (do not mark as tick) -> Package menu -> Force Version -> Select from the list -> Force Version -> Apply

Hope it works for you.