Ubuntu – Can’t I get a wired connection to the new router

lannetworking

I have only had ubuntu for about a month, when i got it i had no problem connecting to our netgear router using an ethernet cable. We have just replaced our router with an identical one (due to lightning blowing our last one up). I was unable to set up the new router on my computer as the disc wouldnt load, so we set it up on my brother win 7 machine. it seems to work fine and i can connect to it wirelessly on my dads ubuntu 10.04 machine.
my computer just doesnt connect, when i go onto network connections in settings it just says cable unplugged, which it isnt. There is no light on for the port my computer is plugged into on the router, although this makes sense as usually the computer has to tell the router it has set up.
i have tried manually setting it up through the network manager using the addresses i got from this machine connected wirelessly, i have tried many restarts under different settings. is there anything i can do to make ubuntu see my connection?
Thankyou

Best Answer

I'd suspect the following statement

There is no light on for the port my computer is plugged into on the router, although this makes sense as usually the computer has to tell the router it has set up.

The port light on your router is typically lit due to, not software or TCP/IP settings, but electrical connectivity. If you plug into the router, and the router's light doesn't go on for that port, you may have a bad port at the router, bad cable, or bad ethernet port on the computer. Possible that you were connected to that router during the lightning strike and took some electrical damage ? I'd get systematic and get my hands on a different cable, try different ports on the router, and also try the same cable and same port with a different computer. Please let me know how your troubleshooting proceeds.

Related Question