Ubuntu – Cant install Steam on the ubuntu 17.04 64 bit

dpkgsteam

When I run sudo apt-get install steam in the terminal, I get these errors:

dpkg: dependency problems prevent configuration of libudev1:i386:
 libudev1:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libudev1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of libgl1-mesa-dri:i386:
 libgl1-mesa-dri:i386 depends on libgcc1 (>= 1:3.4); however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libgl1-mesa-dri:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of libc6:i386:
 libc6:i386 depends on libgcc1; however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libc6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of libtxc-dxtn-s2tc:i386:
 libtxc-dxtn-s2tc:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libtxc-dxtn-s2tc:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libpcre3:i386:
 libpcre3:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libpcre3:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libglapi-mesa:i386:
 libglapi-mesa:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libglapi-mesa:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libblkid1:i386:
 libblkid1:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libblkid1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libdrm2:i386:
 libdrm2:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libdrm2:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb-sync1:i386:
 libxcb-sync1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxcb-sync1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgpg-error0:i386:
 libgpg-error0:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libgpg-error0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libdrm-intel1:i386:
 libdrm-intel1:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.
 libdrm-intel1:i386 depends on libdrm2 (>= 2.4.38); however:
  Package libdrm2:i386 is not configured yet.

dpkg: error processing package libdrm-intel1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libx11-xcb1:i386:
 libx11-xcb1:i386 depends on libc6 (>= 2.1.3); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libx11-xcb1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libllvm4.0:i386:
 libllvm4.0:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.
 libllvm4.0:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libllvm4.0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgl1-mesa-glx:i386:
 libgl1-mesa-glx:i386 depends on libc6 (>= 2.8); however:
  Package libc6:i386 is not configured yet.
 libgl1-mesa-glx:i386 depends on libdrm2 (>= 2.4.66); however:
  Package libdrm2:i386 is not configured yet.
 libgl1-mesa-glx:i386 depends on libglapi-mesa (= 17.0.3-1ubuntu1); however:
  Package libglapi-mesa:i386 is not configured yet.
 libgl1-mesa-glx:i386 depends on libx11-xcb1; however:
  Package libx11-xcb1:i386 is not configured yet.
 libgl1-mesa-glx:i386 depends on libxcb-sync1; however:
  Package libxcb-sync1:i386 is not configured yet.
 libgl1-mesa-glx:i386 depends on libgl1-mesa-dri; however:
  Package libgl1-mesa-dri:i386 is not configured yet.

dpkg: error processing package libgl1-mesa-glx:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libselinux1:i386:
 libselinux1:i386 depends on libc6 (>= 2.8); however:
  Package libc6:i386 is not configured yet.
 libselinux1:i386 depends on libpcre3; however:
  Package libpcre3:i386 is not configured yet.

dpkg: error processing package libselinux1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libpciaccess0:i386:
 libpciaccess0:i386 depends on libc6 (>= 2.7); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libpciaccess0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libsensors4:i386:
 libsensors4:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libsensors4:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libstdc++6:i386:
 libstdc++6:i386 depends on libc6 (>= 2.18); however:
  Package libc6:i386 is not configured yet.
 libstdc++6:i386 depends on libgcc1 (>= 1:4.2); however:
  Package libgcc1:i386 is not installed.

dpkg: error processing package libstdc++6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libffi6:i386:
 libffi6:i386 depends on libc6 (>= 2.7); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libffi6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libdrm-radeon1:i386:
 libdrm-radeon1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libdrm-radeon1:i386 depends on libdrm2 (>= 2.4.38); however:
  Package libdrm2:i386 is not configured yet.

dpkg: error processing package libdrm-radeon1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libcomerr2:i386:
 libcomerr2:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libcomerr2:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxdmcp6:i386:
 libxdmcp6:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxdmcp6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libmount1:i386:
 libmount1:i386 depends on libblkid1 (>= 2.17.2); however:
  Package libblkid1:i386 is not configured yet.
 libmount1:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.
 libmount1:i386 depends on libselinux1 (>= 2.6-3~); however:
  Package libselinux1:i386 is not configured yet.

dpkg: error processing package libmount1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxxf86vm1:i386:
 libxxf86vm1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxxf86vm1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libdrm-nouveau2:i386:
 libdrm-nouveau2:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libdrm-nouveau2:i386 depends on libdrm2 (>= 2.4.38); however:
  Package libdrm2:i386 is not configured yet.

dpkg: error processing package libdrm-nouveau2:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb1:i386:
 libxcb1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libxcb1:i386 depends on libxdmcp6; however:
  Package libxdmcp6:i386 is not configured yet.

dpkg: error processing package libxcb1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxau6:i386:
 libxau6:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxau6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libedit2:i386:
 libedit2:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libedit2:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libncurses5:i386:
 libncurses5:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libncurses5:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb-present0:i386:
 libxcb-present0:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libxcb-present0:i386 depends on libxcb1; however:
  Package libxcb1:i386 is not configured yet.

dpkg: error processing package libxcb-present0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libtinfo5:i386:
 libtinfo5:i386 depends on libc6 (>= 2.16); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libtinfo5:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxinerama1:i386:
 libxinerama1:i386 depends on libc6 (>= 2.1.3); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxinerama1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb-dri2-0:i386:
 libxcb-dri2-0:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libxcb-dri2-0:i386 depends on libxcb1; however:
  Package libxcb1:i386 is not configured yet.

dpkg: error processing package libxcb-dri2-0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb-dri3-0:i386:
 libxcb-dri3-0:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libxcb-dri3-0:i386 depends on libxcb1 (>= 1.9.2); however:
  Package libxcb1:i386 is not configured yet.

dpkg: error processing package libxcb-dri3-0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxcb-glx0:i386:
 libxcb-glx0:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libxcb-glx0:i386 depends on libxcb1; however:
  Package libxcb1:i386 is not configured yet.

dpkg: error processing package libxcb-glx0:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libexpat1:i386:
 libexpat1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libexpat1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of liblzma5:i386:
 liblzma5:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package liblzma5:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxdamage1:i386:
 libxdamage1:i386 depends on libc6 (>= 2.1.3); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxdamage1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of liblz4-1:i386:
 liblz4-1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package liblz4-1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxext6:i386:
 libxext6:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxext6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxfixes3:i386:
 libxfixes3:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxfixes3:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libdrm-amdgpu1:i386:
 libdrm-amdgpu1:i386 depends on libc6 (>= 2.17); however:
  Package libc6:i386 is not configured yet.
 libdrm-amdgpu1:i386 depends on libdrm2 (>= 2.4.60); however:
  Package libdrm2:i386 is not configured yet.

dpkg: error processing package libdrm-amdgpu1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgcrypt20:i386:
 libgcrypt20:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.
 libgcrypt20:i386 depends on libgpg-error0 (>= 1.14); however:
  Package libgpg-error0:i386 is not configured yet.

dpkg: error processing package libgcrypt20:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libuuid1:i386:
 libuuid1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libuuid1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgpm2:i386:
 libgpm2:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libgpm2:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of zlib1g:i386:
 zlib1g:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package zlib1g:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libelf1:i386:
 libelf1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.
 libelf1:i386 depends on zlib1g (>= 1:1.1.4); however:
  Package zlib1g:i386 is not configured yet.

dpkg: error processing package libelf1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxss1:i386:
 libxss1:i386 depends on libc6 (>= 2.1.3); however:
  Package libc6:i386 is not configured yet.
 libxss1:i386 depends on libxext6; however:
  Package libxext6:i386 is not configured yet.

dpkg: error processing package libxss1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libxshmfence1:i386:
 libxshmfence1:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not configured yet.

dpkg: error processing package libxshmfence1:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libx11-6:i386:
 libx11-6:i386 depends on libc6 (>= 2.15); however:
  Package libc6:i386 is not configured yet.
 libx11-6:i386 depends on libxcb1 (>= 1.11.1); however:
  Package libxcb1:i386 is not configured yet.

dpkg: error processing package libx11-6:i386 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 libudev1:i386
 libgl1-mesa-dri:i386
 libc6:i386
 libtxc-dxtn-s2tc:i386
 libpcre3:i386
 libglapi-mesa:i386
 libblkid1:i386
 libdrm2:i386
 libxcb-sync1:i386
 libgpg-error0:i386
 libdrm-intel1:i386
 libx11-xcb1:i386
 libllvm4.0:i386
 libgl1-mesa-glx:i386
 libselinux1:i386
 libpciaccess0:i386
 libsensors4:i386
 libstdc++6:i386
 libffi6:i386
 libdrm-radeon1:i386
 libcomerr2:i386
 libxdmcp6:i386
 libmount1:i386
 libxxf86vm1:i386
 libdrm-nouveau2:i386
 libxcb1:i386
 libxau6:i386
 libedit2:i386
 libncurses5:i386
 libxcb-present0:i386
 libtinfo5:i386
 libxinerama1:i386
 libxcb-dri2-0:i386
 libxcb-dri3-0:i386
 libxcb-glx0:i386
 libexpat1:i386
 liblzma5:i386
 libxdamage1:i386
 liblz4-1:i386
 libxext6:i386
 libxfixes3:i386
 libdrm-amdgpu1:i386
 libgcrypt20:i386
 libuuid1:i386
 libgpm2:i386
 zlib1g:i386
 libelf1:i386
 libxss1:i386
 libxshmfence1:i386
 libx11-6:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Best Answer

  • The first step to fixing this is to enable support for 32 bit binaries. You can do this by running

    sudo dpkg --add-architecture i386 && sudo apt update
    

    Now try installing steam again either from the official site using dpkg or using sudo apt install steam

    If this still doesn't work, try installing the packages manually.

    1. Open up https://packages.ubuntu.com/ in your web browser.
    2. Scroll down to the Search package directories area.
    3. Select your version of ubuntu from the Distribution drop down (In this case it's Zesty).
    4. Type in the package name and click search (In this case it's libgcc1)
    5. Click on the Exact Hit (In this case it's Package libgcc1)
    6. Select i386 in the table at the bottom
    7. Select one of the links on the page. It's probably a good idea to select the one for your country but it doesn't matter.
    8. Open up a terminal and navigate to the directory that you downloaded the package to.
    9. Run sudo dpkg -i file.deb, where file.deb is the file that you just downloaded.

    Once this is done, try to install steam again.

    If it gives you the depends on error for a different package, just follow steps 1-9 for that package and try to install steam. You may have to do this multiple times.

  • Related Question