Ubuntu – Could not calculate the upgrade on distribution upgrade

11.10upgrade

I've been trying to update Ubuntu from 11.04 to 11.10 through Update Manager multiple times since the release but have encountered this error every single time:

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal.

The apt.log contains a lot of messages similar to:

Investigating (8) gnome-control-center [ amd64 ] < 1:2.32.1-0ubuntu15 -> 1:3.2.0-0ubuntu6 > ( gnome )
Broken gnome-control-center:amd64 Depends on libgnome-desktop-3-2 [ amd64 ] < none -> 3.2.0-0ubuntu4 > ( libs ) (>= 3.1.2)
  Considering libgnome-desktop-3-2:amd64 47 as a solution to gnome-control-center:amd64 22
  Holding Back gnome-control-center:amd64 rather than change libgnome-desktop-3-2:amd64

Any ideas what I can do to resolve this?

Best Answer

  • Had a similar issue. I then found this thread - removing the ia32-libs package as rockorequin suggested solved my problem.