Ubuntu – Dash application search unresponsive at startup

unityunity-dash

I'm running Ubuntu 11.10. When I attempt to use the dash to search for an application immediately after log in, the search is unresponsive. I have to open and close the dash several times and attempt several application searches before it returns results for my search.

  • This behaviour happens whether I open the dash with the mouse or the windows key.
  • Although the application search is unresponsive, the file- and music-search functions work just fine.
  • I've noticed that the application icon at the bottom of the dash window is missing until the application search becomes responsive, at which point the icon reappears.
  • If I load an application from the dock (with either my mouse or with the a windows-key and number combination) first, the application search in the dash works fine.

I've done some looking but haven't seen the same problem discussed elsewhere. Some people complaining of dash search issues have reinstalled certain packages, but missing packages don't seem to be the issue here. The search functionality returns after several attempts to use it.

Any help would be greatly appreciated.

Best Answer

  • I have a similar problem. If I've just logged in and attempt to access the dash, then the search field doesn't automatically acknowledge my typing. I have to use my mouse to click on the search field. Or I have to close the dash and open it again.

    The best answer I can give, from my experience, is to wait a bit longer before accessing the dash. Perhaps it's still loading stuff in the background...