Ubuntu – Dual boot Windows 10/Ubuntu Linux 18.04 LTS upgrade to 20.04LTS – Kernel 5.4 is not booting up – freezes after loading ramdisk

bootdual-bootgrub2upgrade

I had successfully running Windows 10 and Ubuntu Linux 18.04 LTS system for almost 2.5 years. Then heard about 20.04 LTS – seems to be smooth installed-i wanted to try it.
I followed this link: How to Upgrade Ubuntu 18.04 LTS to Ubuntu 20.04 LTS.
Did everything from command line. Everything went fine.
I have Linux installed on PCI NVME SSD and Windows 10 on normal SSD.
I used Windows boot loader as the default entry and Ubuntu Linux to be selected if i want to go to Linux.
As per that link, i installed not using kernels to clean up some space.
I was getting purple grub screen.

But after this upgrade – i get this black grub screen. enter image description here on which Linuxes – there are two entries – i don't know which one is default. But if i try to select either of the linux – it doesn't boot Linux and it's all dark screen.

Though on Grub – i can select the entry for Windows and it boots it without any issues.

What went wrong? How to come back to normal life with this upgraded ubuntu Linux 20.04 LTS?
I can select the advanced option and then tried booting 5.4.0-31-generic(kernel which comes with Ubuntu Linux 20.04 LTS)
After that it displays:
Loading Linux 5.4.0-31-generic …
Loading initial ramdisk…
and then stuck/freeze.enter image description here
enter image description here

What could be the issue?
But after selecting Advanced options for Ubuntu when i select
Ubuntu with Linux 4.15.0-101-generic
it shows me same messages
Loading Linux 4.15.0-101-generic…
Loading initial ramdisk…
but not getting stuck or freeze and finally loads new Ubuntu Linux 20.04 LTS

What's going on here?
I checked that 20.04 LTS is installed and working with this choice
root@ashu-XPS-8930:/home/ashu# cat /etc/lsb-release

cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04 LTS"

And the version of Linux kernel is only 4.15.0-101-generic
as per this

root@ashu-XPS-8930:/home/ashu# uname -r 
4.15.0-101-generic

Seems to be an existing bug at the time of upgrade
Or is it the case that last update was not done well

# **sudo apt list --upgradable**
Listing... Done
accountsservice/focal-updates 0.6.55-0ubuntu12~20.04.1 amd64 [upgradable from: 0.6.55-0ubuntu11]
adwaita-icon-theme/focal-updates,focal-updates 3.36.1-2ubuntu0.20.04.2 all [upgradable from: 3.36.0-1ubuntu1]
alsa-ucm-conf/focal-updates,focal-updates 1.2.2-1ubuntu0.1 all [upgradable from: 1.2.2-1]
apparmor/focal-updates 2.13.3-7ubuntu5.1 amd64 [upgradable from: 2.13.3-7ubuntu5]
apport-gtk/focal-updates,focal-updates 2.20.11-0ubuntu27.3 all [upgradable from: 2.20.11-0ubuntu27]
apport/focal-updates,focal-updates 2.20.11-0ubuntu27.3 all [upgradable from: 2.20.11-0ubuntu27]
aptdaemon-data/focal-updates,focal-updates 1.1.1+bzr982-0ubuntu32.1 all [upgradable from: 1.1.1+bzr982-0ubuntu32]
aptdaemon/focal-updates,focal-updates 1.1.1+bzr982-0ubuntu32.1 all [upgradable from: 1.1.1+bzr982-0ubuntu32]
bind9-dnsutils/focal-updates,focal-security 1:9.16.1-0ubuntu2.2 amd64 [upgradable from: 1:9.16.1-0ubuntu2.1]
bind9-host/focal-updates,focal-security 1:9.16.1-0ubuntu2.2 amd64 [upgradable from: 1:9.16.1-0ubuntu2.1]
bind9-libs/focal-updates,focal-security 1:9.16.1-0ubuntu2.2 amd64 [upgradable from: 1:9.16.1-0ubuntu2.1]
busybox-initramfs/focal-updates 1:1.30.1-4ubuntu6.1 amd64 [upgradable from: 1:1.30.1-4ubuntu6]
busybox-static/focal-updates 1:1.30.1-4ubuntu6.1 amd64 [upgradable from: 1:1.30.1-4ubuntu6]
curl/focal-updates,focal-security 7.68.0-1ubuntu2.1 amd64 [upgradable from: 7.68.0-1ubuntu2]
dbus-user-session/focal-updates,focal-security 1.12.16-2ubuntu2.1 amd64 [upgradable from: 1.12.16-2ubuntu2]
dbus-x11/focal-updates,focal-security 1.12.16-2ubuntu2.1 amd64 [upgradable from: 1.12.16-2ubuntu2]
dbus/focal-updates,focal-security 1.12.16-2ubuntu2.1 amd64 [upgradable from: 1.12.16-2ubuntu2]
deja-dup/focal-updates 40.7-0ubuntu1 amd64 [upgradable from: 40.6-1ubuntu2]
desktop-file-utils/focal-updates 0.24-1ubuntu3 amd64 [upgradable from: 0.24-1ubuntu2]
dnsutils/focal-updates,focal-updates,focal-security,focal-security 1:9.16.1-0ubuntu2.2 all [upgradable from: 1:9.16.1-0ubuntu2.1]
docker.io/focal-updates 19.03.8-0ubuntu1.20.04 amd64 [upgradable from: 19.03.8-0ubuntu1]
evince-common/focal-updates,focal-updates 3.36.5-0ubuntu1 all [upgradable from: 3.36.0-2]
evince/focal-updates 3.36.5-0ubuntu1 amd64 [upgradable from: 3.36.0-2]
evolution-data-server-common/focal-updates,focal-updates 3.36.3-0ubuntu1 all [upgradable from: 3.36.2-0ubuntu1]
evolution-data-server/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
firefox-locale-en/focal-updates,focal-security 78.0.1+build1-0ubuntu0.20.04.1 amd64 [upgradable from: 76.0.1+build1-0ubuntu0.20.04.1]
firefox/focal-updates,focal-security 78.0.1+build1-0ubuntu0.20.04.1 amd64 [upgradable from: 76.0.1+build1-0ubuntu0.20.04.1]
fonts-opensymbol/focal-updates,focal-updates 2:102.11+LibO6.4.4-0ubuntu0.20.04.1 all [upgradable from: 2:102.11+LibO6.4.3-0ubuntu0.20.04.1]
fwupd-signed/focal-updates,focal-security 1.27.1ubuntu1+1.3.9-4ubuntu0.1 amd64 [upgradable from: 1.27+1.3.9-4]
fwupd/focal-updates,focal-security 1.3.9-4ubuntu0.1 amd64 [upgradable from: 1.3.9-4]
gamemode/focal-updates 1.5.1-0ubuntu3.1 amd64 [upgradable from: 1.5.1-0ubuntu3]
gir1.2-accountsservice-1.0/focal-updates 0.6.55-0ubuntu12~20.04.1 amd64 [upgradable from: 0.6.55-0ubuntu11]
gir1.2-freedesktop/focal-updates 1.64.1-1~ubuntu20.04.1 amd64 [upgradable from: 1.64.0-2]
gir1.2-glib-2.0/focal-updates 1.64.1-1~ubuntu20.04.1 amd64 [upgradable from: 1.64.0-2]
gir1.2-gnomedesktop-3.0/focal-updates 3.36.2-0ubuntu2 amd64 [upgradable from: 3.36.2-0ubuntu1]
gir1.2-gtk-3.0/focal-updates 3.24.20-0ubuntu1 amd64 [upgradable from: 3.24.18-1ubuntu1]
gir1.2-mutter-6/focal-updates 3.36.3-0ubuntu0.20.04.1 amd64 [upgradable from: 3.36.2-1ubuntu1~20.04.1]
gir1.2-nm-1.0/focal-updates 1.22.10-1ubuntu2.1 amd64 [upgradable from: 1.22.10-1ubuntu1]
gir1.2-vte-2.91/focal-updates 0.60.3-0ubuntu1~20.04 amd64 [upgradable from: 0.60.1-1ubuntu1]
gjs/focal-updates 1.64.3-1~ubuntu20.04.1 amd64 [upgradable from: 1.64.2-1ubuntu1~20.04.1]
glib-networking-common/focal-updates,focal-updates,focal-security,focal-security 2.64.2-1ubuntu0.1 all [upgradable from: 2.64.2-1build1]
glib-networking-services/focal-updates,focal-security 2.64.2-1ubuntu0.1 amd64 [upgradable from: 2.64.2-1build1]
glib-networking/focal-updates,focal-security 2.64.2-1ubuntu0.1 amd64 [upgradable from: 2.64.2-1build1]
gnome-desktop3-data/focal-updates,focal-updates 3.36.2-0ubuntu2 all [upgradable from: 3.36.2-0ubuntu1]
gnome-logs/focal-updates 3.34.0-1ubuntu1 amd64 [upgradable from: 3.34.0-1]
gnome-shell-common/focal-updates,focal-updates 3.36.3-1ubuntu1~20.04.2 all [upgradable from: 3.36.2-1ubuntu1~20.04.1]
gnome-shell-extension-desktop-icons/focal-updates,focal-updates 20.04.0-2~ubuntu20.04.1 all [upgradable from: 20.04.0-1]
gnome-shell-extension-ubuntu-dock/focal-updates,focal-updates 68ubuntu1~20.04.1 all [upgradable from: 67ubuntu20.04.5]
gnome-shell/focal-updates 3.36.3-1ubuntu1~20.04.2 amd64 [upgradable from: 3.36.2-1ubuntu1~20.04.1]
gnome-terminal-data/focal-updates,focal-updates 3.36.2-1ubuntu1~20.04 all [upgradable from: 3.36.1.1-1ubuntu1]
gnome-terminal/focal-updates 3.36.2-1ubuntu1~20.04 amd64 [upgradable from: 3.36.1.1-1ubuntu1]
google-chrome-stable/stable 83.0.4103.116-1 amd64 [upgradable from: 83.0.4103.61-1]
gtk-update-icon-cache/focal-updates 3.24.20-0ubuntu1 amd64 [upgradable from: 3.24.18-1ubuntu1]
initramfs-tools-bin/focal-updates 0.136ubuntu6.2 amd64 [upgradable from: 0.136ubuntu6]
initramfs-tools-core/focal-updates,focal-updates 0.136ubuntu6.2 all [upgradable from: 0.136ubuntu6]
initramfs-tools/focal-updates,focal-updates 0.136ubuntu6.2 all [upgradable from: 0.136ubuntu6]
intel-microcode/focal-updates,focal-security 3.20200609.0ubuntu0.20.04.2 amd64 [upgradable from: 3.20191115.1ubuntu3]
libaccountsservice0/focal-updates 0.6.55-0ubuntu12~20.04.1 amd64 [upgradable from: 0.6.55-0ubuntu11]
libapparmor1/focal-updates 2.13.3-7ubuntu5.1 amd64 [upgradable from: 2.13.3-7ubuntu5]
libasound2-data/focal-updates,focal-updates 1.2.2-2.1ubuntu1 all [upgradable from: 1.2.2-2.1]
libasound2/focal-updates 1.2.2-2.1ubuntu1 amd64 [upgradable from: 1.2.2-2.1]
libatk-adaptor/focal-updates 2.34.2-0ubuntu2~20.04.1 amd64 [upgradable from: 2.34.1-3]
libatk-bridge2.0-0/focal-updates 2.34.2-0ubuntu2~20.04.1 amd64 [upgradable from: 2.34.1-3]
libatopology2/focal-updates 1.2.2-2.1ubuntu1 amd64 [upgradable from: 1.2.2-2.1]
libcamel-1.2-62/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libcurl3-gnutls/focal-updates,focal-security 7.68.0-1ubuntu2.1 amd64 [upgradable from: 7.68.0-1ubuntu2]
libcurl4/focal-updates,focal-security 7.68.0-1ubuntu2.1 amd64 [upgradable from: 7.68.0-1ubuntu2]
libdbus-1-3/focal-updates,focal-security 1.12.16-2ubuntu2.1 amd64 [upgradable from: 1.12.16-2ubuntu2]
libebackend-1.2-10/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libebook-1.2-20/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libebook-contacts-1.2-3/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libecal-2.0-1/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libedata-book-1.2-26/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libedata-cal-2.0-1/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libedataserver-1.2-24/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libedataserverui-1.2-2/focal-updates 3.36.3-0ubuntu1 amd64 [upgradable from: 3.36.2-0ubuntu1]
libegl-mesa0/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libegl1-mesa/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libevdocument3-4/focal-updates 3.36.5-0ubuntu1 amd64 [upgradable from: 3.36.0-2]
libevview3-3/focal-updates 3.36.5-0ubuntu1 amd64 [upgradable from: 3.36.0-2]
libexif12/focal-updates,focal-security 0.6.21-6ubuntu0.3 amd64 [upgradable from: 0.6.21-6ubuntu0.1]
libfwupd2/focal-updates,focal-security 1.3.9-4ubuntu0.1 amd64 [upgradable from: 1.3.9-4]
libfwupdplugin1/focal-updates,focal-security 1.3.9-4ubuntu0.1 amd64 [upgradable from: 1.3.9-4]
libgail-3-0/focal-updates 3.24.20-0ubuntu1 amd64 [upgradable from: 3.24.18-1ubuntu1]
libgamemode0/focal-updates 1.5.1-0ubuntu3.1 amd64 [upgradable from: 1.5.1-0ubuntu3]
libgamemodeauto0/focal-updates 1.5.1-0ubuntu3.1 amd64 [upgradable from: 1.5.1-0ubuntu3]
libgbm1/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libgirepository-1.0-1/focal-updates 1.64.1-1~ubuntu20.04.1 amd64 [upgradable from: 1.64.0-2]
libgjs0g/focal-updates 1.64.3-1~ubuntu20.04.1 amd64 [upgradable from: 1.64.2-1ubuntu1~20.04.1]
libgl1-mesa-dri/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libgl1-mesa-dri/focal-updates 20.0.8-0ubuntu1~20.04.1 i386 [upgradable from: 20.0.4-2ubuntu1]
libgl1-mesa-glx/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libglapi-mesa/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libglapi-mesa/focal-updates 20.0.8-0ubuntu1~20.04.1 i386 [upgradable from: 20.0.4-2ubuntu1]
libglx-mesa0/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libglx-mesa0/focal-updates 20.0.8-0ubuntu1~20.04.1 i386 [upgradable from: 20.0.4-2ubuntu1]
libgnome-desktop-3-19/focal-updates 3.36.2-0ubuntu2 amd64 [upgradable from: 3.36.2-0ubuntu1]
libgnutls30/focal-updates 3.6.13-2ubuntu1.2 amd64 [upgradable from: 3.6.13-2ubuntu1]
libgtk-3-0/focal-updates 3.24.20-0ubuntu1 amd64 [upgradable from: 3.24.18-1ubuntu1]
libgtk-3-bin/focal-updates 3.24.20-0ubuntu1 amd64 [upgradable from: 3.24.18-1ubuntu1]
libgtk-3-common/focal-updates,focal-updates 3.24.20-0ubuntu1 all [upgradable from: 3.24.18-1ubuntu1]
libjpeg-turbo8/focal-updates,focal-security 2.0.3-0ubuntu1.20.04.1 amd64 [upgradable from: 2.0.3-0ubuntu1]
libjuh-java/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libjurt-java/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
liblilv-0-0/focal-updates 0.24.6-1ubuntu0.1 amd64 [upgradable from: 0.24.6-1]
libmutter-6-0/focal-updates 3.36.3-0ubuntu0.20.04.1 amd64 [upgradable from: 3.36.2-1ubuntu1~20.04.1]
libnautilus-extension1a/focal-updates 1:3.36.3-0ubuntu1 amd64 [upgradable from: 1:3.36.2-0ubuntu1]
libnetplan0/focal-updates 0.99-0ubuntu3~20.04.2 amd64 [upgradable from: 0.99-0ubuntu3~20.04.1]
libnm0/focal-updates 1.22.10-1ubuntu2.1 amd64 [upgradable from: 1.22.10-1ubuntu1]
libnss3/focal-updates,focal-security 2:3.49.1-1ubuntu1.1 amd64 [upgradable from: 2:3.49.1-1ubuntu1]
libproxy1-plugin-gsettings/focal-updates 0.4.15-10ubuntu1 amd64 [upgradable from: 0.4.15-10]
libproxy1-plugin-networkmanager/focal-updates 0.4.15-10ubuntu1 amd64 [upgradable from: 0.4.15-10]
libproxy1v5/focal-updates 0.4.15-10ubuntu1 amd64 [upgradable from: 0.4.15-10]
libpulse-mainloop-glib0/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
libpulse0/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
libpulsedsp/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
libreoffice-avmedia-backend-gstreamer/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-base-core/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-calc/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-common/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-core/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-draw/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-gnome/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-gtk3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-help-common/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-help-en-us/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-impress/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-math/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-ogltrans/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-pdfimport/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-style-breeze/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-style-colibre/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-style-elementary/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-style-galaxy/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-style-tango/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libreoffice-writer/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libridl-java/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libseccomp2/focal-updates,focal-security 2.4.3-1ubuntu3.20.04.2 amd64 [upgradable from: 2.4.3-1ubuntu1]
libsmbclient/focal-updates,focal-security 2:4.11.6+dfsg-0ubuntu1.3 amd64 [upgradable from: 2:4.11.6+dfsg-0ubuntu1.2]
libsnmp-base/focal-updates,focal-updates,focal-security,focal-security 5.8+dfsg-2ubuntu2.1 all [upgradable from: 5.8+dfsg-2ubuntu2]
libsnmp35/focal-updates,focal-security 5.8+dfsg-2ubuntu2.1 amd64 [upgradable from: 5.8+dfsg-2ubuntu2]
libsqlite3-0/focal-updates,focal-security 3.31.1-4ubuntu0.1 amd64 [upgradable from: 3.31.1-4]
libuno-cppu3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libuno-cppuhelpergcc3-3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libuno-purpenvhelpergcc3-3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libuno-sal3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libuno-salhelpergcc3-3/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libunoloader-java/focal-updates,focal-updates 1:6.4.4-0ubuntu0.20.04.1 all [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
libvncclient1/focal-updates,focal-security 0.9.12+dfsg-9ubuntu0.1 amd64 [upgradable from: 0.9.12+dfsg-9]
libvte-2.91-0/focal-updates 0.60.3-0ubuntu1~20.04 amd64 [upgradable from: 0.60.1-1ubuntu1]
libvte-2.91-common/focal-updates 0.60.3-0ubuntu1~20.04 amd64 [upgradable from: 0.60.1-1ubuntu1]
libwayland-egl1-mesa/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
libwbclient0/focal-updates,focal-security 2:4.11.6+dfsg-0ubuntu1.3 amd64 [upgradable from: 2:4.11.6+dfsg-0ubuntu1.2]
libxatracker2/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
linux-firmware/focal-updates,focal-updates 1.187.1 all [upgradable from: 1.187]
linux-generic/focal-updates,focal-security 5.4.0.40.43 amd64 [upgradable from: 5.4.0.33.38]
linux-headers-generic/focal-updates,focal-security 5.4.0.40.43 amd64 [upgradable from: 5.4.0.33.38]
linux-image-generic/focal-updates,focal-security 5.4.0.40.43 amd64 [upgradable from: 5.4.0.33.38]
linux-libc-dev/focal-updates,focal-security 5.4.0-40.44 amd64 [upgradable from: 5.4.0-33.37]
login/focal-updates 1:4.8.1-1ubuntu5.20.04 amd64 [upgradable from: 1:4.8.1-1ubuntu5]
mesa-va-drivers/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
mesa-vdpau-drivers/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
mesa-vulkan-drivers/focal-updates 20.0.8-0ubuntu1~20.04.1 amd64 [upgradable from: 20.0.4-2ubuntu1]
mesa-vulkan-drivers/focal-updates 20.0.8-0ubuntu1~20.04.1 i386 [upgradable from: 20.0.4-2ubuntu1]
mutter-common/focal-updates,focal-updates 3.36.3-0ubuntu0.20.04.1 all [upgradable from: 3.36.2-1ubuntu1~20.04.1]
mutter/focal-updates 3.36.3-0ubuntu0.20.04.1 amd64 [upgradable from: 3.36.2-1ubuntu1~20.04.1]
nautilus-data/focal-updates,focal-updates 1:3.36.3-0ubuntu1 all [upgradable from: 1:3.36.2-0ubuntu1]
nautilus-extension-gnome-terminal/focal-updates 3.36.2-1ubuntu1~20.04 amd64 [upgradable from: 3.36.1.1-1ubuntu1]
nautilus/focal-updates 1:3.36.3-0ubuntu1 amd64 [upgradable from: 1:3.36.2-0ubuntu1]
netplan.io/focal-updates 0.99-0ubuntu3~20.04.2 amd64 [upgradable from: 0.99-0ubuntu3~20.04.1]
network-manager-config-connectivity-ubuntu/focal-updates,focal-updates 1.22.10-1ubuntu2.1 all [upgradable from: 1.22.10-1ubuntu1]
network-manager/focal-updates 1.22.10-1ubuntu2.1 amd64 [upgradable from: 1.22.10-1ubuntu1]
openssh-client/focal-updates 1:8.2p1-4ubuntu0.1 amd64 [upgradable from: 1:8.2p1-4]
orca/focal-updates,focal-updates 3.36.2-1ubuntu1~20.04.1 all [upgradable from: 3.36.1-0ubuntu1]
passwd/focal-updates 1:4.8.1-1ubuntu5.20.04 amd64 [upgradable from: 1:4.8.1-1ubuntu5]
pulseaudio-module-bluetooth/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
pulseaudio-utils/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
pulseaudio/focal-updates 1:13.99.1-1ubuntu3.3 amd64 [upgradable from: 1:13.99.1-1ubuntu3.2]
python3-apport/focal-updates,focal-updates 2.20.11-0ubuntu27.3 all [upgradable from: 2.20.11-0ubuntu27]
python3-aptdaemon.gtk3widgets/focal-updates,focal-updates 1.1.1+bzr982-0ubuntu32.1 all [upgradable from: 1.1.1+bzr982-0ubuntu32]
python3-aptdaemon/focal-updates,focal-updates 1.1.1+bzr982-0ubuntu32.1 all [upgradable from: 1.1.1+bzr982-0ubuntu32]
python3-problem-report/focal-updates,focal-updates 2.20.11-0ubuntu27.3 all [upgradable from: 2.20.11-0ubuntu27]
python3-uno/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
python3-update-manager/focal-updates,focal-updates 1:20.04.10.1 all [upgradable from: 1:20.04.10]
samba-libs/focal-updates,focal-security 2:4.11.6+dfsg-0ubuntu1.3 amd64 [upgradable from: 2:4.11.6+dfsg-0ubuntu1.2]
shotwell-common/focal-updates,focal-updates 0.30.10-0ubuntu0.1 all [upgradable from: 0.30.8-0ubuntu2]
shotwell/focal-updates 0.30.10-0ubuntu0.1 amd64 [upgradable from: 0.30.8-0ubuntu2]
thermald/focal-updates 1.9.1-1ubuntu0.2 amd64 [upgradable from: 1.9.1-1ubuntu0.1]
ubuntu-desktop-minimal/focal-updates 1.450.1 amd64 [upgradable from: 1.450]
ubuntu-desktop/focal-updates 1.450.1 amd64 [upgradable from: 1.450]
ubuntu-minimal/focal-updates 1.450.1 amd64 [upgradable from: 1.450]
ubuntu-standard/focal-updates 1.450.1 amd64 [upgradable from: 1.450]
uno-libs-private/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
update-manager-core/focal-updates,focal-updates 1:20.04.10.1 all [upgradable from: 1:20.04.10]
update-manager/focal-updates,focal-updates 1:20.04.10.1 all [upgradable from: 1:20.04.10]
ure/focal-updates 1:6.4.4-0ubuntu0.20.04.1 amd64 [upgradable from: 1:6.4.3-0ubuntu0.20.04.1]
wpasupplicant/focal-updates 2:2.9-1ubuntu4.1 amd64 [upgradable from: 2:2.9-1ubuntu4]
xserver-common/focal-updates,focal-updates 2:1.20.8-2ubuntu2.1 all [upgradable from: 2:1.20.8-2ubuntu2]
xserver-xephyr/focal-updates 2:1.20.8-2ubuntu2.1 amd64 [upgradable from: 2:1.20.8-2ubuntu2]
xserver-xorg-core/focal-updates 2:1.20.8-2ubuntu2.1 amd64 [upgradable from: 2:1.20.8-2ubuntu2]
xserver-xorg-legacy/focal-updates 2:1.20.8-2ubuntu2.1 amd64 [upgradable from: 2:1.20.8-2ubuntu2]
xwayland/focal-updates 2:1.20.8-2ubuntu2.1 amd64 [upgradable from: 2:1.20.8-2ubuntu2]
yaru-theme-gnome-shell/focal-updates,focal-updates 20.04.7 all [upgradable from: 20.04.6]
yaru-theme-gtk/focal-updates,focal-updates 20.04.7 all [upgradable from: 20.04.6]
yaru-theme-icon/focal-updates,focal-updates 20.04.7 all [upgradable from: 20.04.6]
yaru-theme-sound/focal-updates,focal-updates 20.04.7 all [upgradable from: 20.04.6]

Update
I tried installing various other kernels thinking that it might fix this problem but no luck.
enter image description here

Best Answer

  • Did you try step 2 again (removing kernels)?

    Step 2) Remove unused Kernels and install ‘update-manager-core’

    Once your Ubuntu 18.04 LTS desktop is available after reboot, then it is recommended to remove unused kernels to free up the space from /boot partition, run beneath command:

    pkumar@LinuxTechi:~$ sudo apt --purge autoremove

  • Related Question