Ubuntu – E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages


I've been trying to install the CoreBird Twitter application and have had horrible luck with getting it to compile and then I came across a deb (from here) and tried to install it that way.

However, I got this error:

 corebird depends on libglib2.0-0 (>= 2.41.1); however:
  Package libglib2.0-0:amd64 is not configured yet.
 corebird depends on libgtk-3-0 (>= 3.13.7); however:
  Version of libgtk-3-0:amd64 on system is 3.10.8-0ubuntu1.4.

So, I tried to be smart and manually track down and install those libraries. I found the correct deb file, but when I ran dpkg -i for the libglib deb, I got this:

pkg: error processing package libglib2.0-0:amd64 (--install):
 package libglib2.0-0:amd64 2.42.0-2 cannot be configured because libglib2.0-0:i386 is at a different version (2.40.2-0ubuntu1)

and something else about not being able to configure it because libglib2.0-0:amd64 was the wrong version.

This is where I went wrong. I, without thinking, ran sudo apt-get remove libglib2.0-0:amd64.

So, obviously, it created a crap ton of dependency issues and told me to run sudo apt-get -f install. I did that, and now I get this:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 corebird : Depends: libgtk-3-0 (>= 3.13.7) but 3.10.8-0ubuntu1.4 is installed
 libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.42.0-2) but 2.40.2-0ubuntu1 is installed
 libglib2.0-0:i386 : Breaks: libglib2.0-0 (!= 2.40.2-0ubuntu1) but 2.42.0-2 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.42.0-2 is installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.40.2-0ubuntu1) but 2.42.0-2 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Apparently, the glib 2.42.0-2 package installed after I removed the previously installed 2.40.2, and is now causing all sorts of issues. Obviously, this is an issue.

Does anyone know how to fix this issue?

My /var/log/dist-upgrade/apt.log file is empty:

cat /var/log/dist-upgrade/apt.log
cat: /var/log/dist-upgrade/apt.log: No such file or directory

and the command dpkg --get-selections | grep hold returns nothing:

$ dpkg --get-selections | grep hold


This question is not a duplicate. I can't install aptitude even if I wanted to (same error.)

Best Answer

I would try to do it like that:

sudo apt-get remove corebird
sudo apt-get -f install

Then make sure that everything is back to normal.

After that, change repos in /etc/apt/sources.list to vivid and get the needed libraries through apt-get.

Install corebird with dpkg.

Change /etc/apt/sources.list back to trusty.

Related Question