Ubuntu – E: Package ‘libssl1.0.0’ has no installation candidate

software installation

I get this error message when I try to install libssl1.0.0'.

How can I solve it? I use Ubuntu 19.04

Best Answer

  • The results of rmadison libssl1.0.0 show that the libssl1.0.0 package was dropped from the default Ubuntu repositories after Ubuntu 18.04.

    $ rmadison libssl1.0.0
     libssl1.0.0 | 1.0.1-4ubuntu3     | precise          | amd64, armel, armhf, i386, powerpc
     libssl1.0.0 | 1.0.1-4ubuntu5.39  | precise-security | amd64, armel, armhf, i386, powerpc
     libssl1.0.0 | 1.0.1-4ubuntu5.39  | precise-updates  | amd64, armel, armhf, i386, powerpc
     libssl1.0.0 | 1.0.1f-1ubuntu2    | trusty           | amd64, arm64, armhf, i386, powerpc, ppc64el
     libssl1.0.0 | 1.0.1f-1ubuntu2.27 | trusty-security  | amd64, arm64, armhf, i386, powerpc, ppc64el
     libssl1.0.0 | 1.0.1f-1ubuntu2.27 | trusty-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el
     libssl1.0.0 | 1.0.2g-1ubuntu4    | xenial           | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
     libssl1.0.0 | 1.0.2g-1ubuntu4.15 | xenial-security  | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
     libssl1.0.0 | 1.0.2g-1ubuntu4.15 | xenial-updates   | amd64, arm64, armhf, i386, powerpc, ppc64el, s390x
     libssl1.0.0 | 1.0.2n-1ubuntu5    | bionic           | amd64, arm64, armhf, i386, ppc64el, s390x
     libssl1.0.0 | 1.0.2n-1ubuntu5.3  | bionic-security  | amd64, arm64, armhf, i386, ppc64el, s390x
     libssl1.0.0 | 1.0.2n-1ubuntu5.3  | bionic-updates   | amd64, arm64, armhf, i386, ppc64el, s390x

    The results of apt search libssl show that the libssl package has been upgraded to libssl1.1 in Ubuntu 19.04 (and later). To install it open the terminal and type:

    sudo apt install libssl1.1