Ubuntu – E: The package libreoffice6.2-debian-menus needs to be reinstalled, but I can’t find an archive for it

libreofficepackage-management

I keep getting this error message
I'm on Ubuntu 18.04.
I downloaded the latest stable deb version of LibreOffice 6.2.6 ran install and

E: The package libreoffice6.2-debian-menus needs to be reinstalled, but I can't find an archive for it.

I've tried fixing broken packages, updating, complete removal using package manager but nothing has worked.
My backup won't even work now.
Opening Synaptic I get this

E: The package libreoffice6.2-debian-menus needs to be reinstalled, but I can't find an archive for it.
E: Internal error opening cache (1). Please report.

Then Package manager shuts down

Best Answer

There are 3 steps to take to get to the current version of LibreOffice 6 which I have completed in 18.04 (and 16.04) without problems.

  1. Add the LibreOffice PPA. Open a terminal and type:

    sudo add-apt-repository ppa:libreoffice/ppa
    
  2. Update your system by running this command in terminal:

    sudo apt update
    
  3. Finally run this command in terminal to upgrade or install LibreOffice

    sudo apt install libreoffice
    

Then as any updates are available, they will be automatically offered according to your preferences in Software Updater.