Ubuntu – Error: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit -.mount is masked

lubuntumount

Linux Distro: Lubuntu 19.04

My system is working fine but I just get distracted when I update my packages because of this error which I don't know how to fix. I've been finding some related topics and I tried their solution but still fail to fix the error.sudo apt update gives this error

sudo apt update
Hit:1 http://repo.steampowered.com/steam precise InRelease
Hit:2 http://packages.microsoft.com/repos/vscode stable InRelease              
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:5 http://archive.ubuntu.com/ubuntu disco InRelease
Hit:6 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu disco InRelease
Hit:8 http://archive.ubuntu.com/ubuntu disco-updates InRelease           
Hit:9 http://archive.ubuntu.com/ubuntu disco-security InRelease          
Hit:10 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu disco InRelease
Error: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit -.mount is masked.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.

Edit: Here is the results of the terminal whenever I use update. Sorry for inconvenience.

Best Answer

  • I had this error when GParted was open. After I closed it, the error vanished.

  • Related Question