Ubuntu – Error while loading shared libraries: libQt5Sql.so.5 when installing Cisco Packet Tracer 7.2.2

cisconetworking

Initially, I had this problem after installing Cisco Packet Tracer 7.2.2

user@linux:~$ /opt/pt/bin/PacketTracer7
/opt/pt/bin/PacketTracer7: error while loading shared libraries: libQt5WebKitWidgets.so.5: cannot open shared object file: No such file or directory
user@linux:~$ 

It turns out 5 libraries were not found.

user@linux:~$ ldd /opt/pt/bin/PacketTracer7 | grep no
    libQt5WebKitWidgets.so.5 => not found
    libQt5WebKit.so.5 => not found
    libQt5Multimedia.so.5 => not found
    libQt5ScriptTools.so.5 => not found
    libQt5Sql.so.5 => not found
user@linux:~$ 

I followed suggestion from chili555 and managed to fix 4 of them
https://askubuntu.com/a/987765/769117

sudo apt install libqt5webkit5 libqt5multimedia5 libqt5printsupport5 libqt5script5 libqt5scripttools5 

Then, I launched PacketTracer7 and found another one was missed which was libQt5Sql.so.5.

user@linux:~$ /opt/pt/bin/PacketTracer7 
/opt/pt/bin/PacketTracer7: error while loading shared libraries: libQt5Sql.so.5: cannot open shared object file: No such file or directory
user@linux:~$ 

Checked ldd again, and verified libQt5Sql.so.5 was missing. The other 4 were fixed on previous update.

user@linux:~$ ldd /opt/pt/bin/PacketTracer7 | grep no
    libQt5Sql.so.5 => not found
user@linux:~$ 

I tried to installed it but didn't work

user@linux:~$ sudo apt install libQt5Sql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libQt5Sql
user@linux:~$ 

I did not see anything helpful in syslog

user@linux:~$ cat /var/log/syslog | grep acket
user@linux:~$ 

What should I do to fix this?

Best Answer

  • Had the same issue. All of those libs are present in /opt/pt/bin, so if you start PacketTracer from there, it will work.

    ana@catalyst:/opt/pt/bin$ ./PacketTracer7