Ubuntu – Errors were encountered while processing: /var/cache/apt/archives/click_0.4.38.5ubuntu0.2_amd64.deb

click-packagesdpkg

I'm getting trouble by the error:

click-system-hooks.service couldn't start.
Errors were encountered while processing:  /var/cache/apt/archives/click_0.4.38.5ubuntu0.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

It's also showing this message:

enter image description here

How to solve it?

I have tried:

$ sudo dpkg --configure -a
$ sudo apt-get install systemd

And the output is:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
systemd is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
click : Depends: python3-click (= 0.4.38.5) but 0.4.38.5ubuntu0.2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried running sudo apt-get -f install, as suggested, and the output is:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
at bzr-builddeb debian-archive-keyring devscripts distro-info
distro-info-data dput libdistro-info-perl
libexporter-lite-perl libio-stringy-perl
libparse-debcontrol-perl libtie-ixhash-perl libxdelta2
pbuilder pbzip2 pristine-tar pybootchartgui python-debianbts
python-defusedxml python-distro-info python-lzma
python-reportbug python-requests python-soappy
python-ubuntutools python-wstools quilt reportbug
ubuntu-dev-tools xdelta
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
click
Suggested packages:
ubuntu-app-launch-tools upstart-app-launch-tools
The following packages will be upgraded:
click
1 upgraded, 0 newly installed, 0 to remove and 38 not upgraded.
Need to get 0 B/14.4 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 560681 files and directories currently installed.)
Preparing to unpack .../click_0.4.38.5ubuntu0.2_amd64.deb ...
Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (var)! ********************
Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (cryptswap1)! 
Broadcast message from root@....... (Fri 2015-10-23 23:03:00 ICT):

Password entry required for 'Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (cryptswap1)!' (PID 11194).
Please enter password with the systemd-tty-ask-password-agent tool!

**********

Traceback (most recent call last):
File "/usr/bin/click", line 31, in <module
    from click import commands
ImportError: cannot import name 'commands'
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
Traceback (most recent call last):
File "/usr/bin/click", line 31, in <module
    from click import commands
ImportError: cannot import name 'commands'
dpkg: error processing archive /var/cache/apt/archives/click_0.4.38.5ubuntu0.2_amd64.deb (--unpack):
subprocess new pre-removal script returned error exit status 1

Broadcast message from root@........(Fri 2015-10-23 23:03:05 ICT):

Password entry required for 'Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (var)!' (PID 13188).
Please enter password with the systemd-tty-ask-password-agent tool!


Broadcast message from root@......... (Fri 2015-10-23 23:03:05 ICT):

Password entry required for 'Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (cryptswap1)!' (PID 13187).
Please enter password with the systemd-tty-ask-password-agent tool!


Broadcast message from root@......... (Fri 2015-10-23 23:03:05 ICT):

Password entry required for 'Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (var)!' (PID 13188).
Please enter password with the systemd-tty-ask-password-agent tool!

Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (cryptswap1)! Job for click-system-hooks.service failed. See "systemctl status click-system-hooks.service" and "journalctl -xe" for details.
*****************

Broadcast message from root@........... (Fri 2015-10-23 23:03:10 ICT):

Password entry required for 'Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (var)!' (PID 13188).
Please enter password with the systemd-tty-ask-password-agent tool!

Please enter passphrase for disk Samsung_SSD_850_EVO_120GB (var)! ******************

click-system-hooks.service couldn't start.

Errors were encountered while processing:
/var/cache/apt/archives/click_0.4.38.5ubuntu0.2_amd64.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

Best Answer

  • It looks that don't have systemd, but installer false detects it installed. It is a known bug in Ubunutu #1448623. Make sure, the systemd is installed

    dpkg --configure -a
    apt-get install systemd
    

    Then purge click, as suggested in this comment by weiqi_chen

    sudo pip3 uninstall click
    sudo apt-get purge click
    
  • Related Question