Ubuntu – Ethernet not working on Dell WD15 docking station and Latitude 5491 – 16.04

delldockingethernetnetworking

I have a Dell Latitude 5491 connected to a docking station WD15 with dual-boot Windows/Ubuntu.

Ethernet is not working only when it is connected through the docking station and on Ubuntu. It works when the ethernet cable is connected directly to the computer.

It works on Windows (with and without docking station).

Therefore it can not be the cable

My kernel version is: 4.15.0-46-generic

Wifi is working without problems both on ubuntu and windows.

What can be the problem?

EDIT: I found out, by looking at other answers on stackexchange that this should be a problem of kernel. By downgrading the kernel I might be able to get this thing right. However, I did not want to do this.

EDIT2: Another thing I found out is that I do NOT have this problem if I boot my laptop without the dock, then after boot is complete I can connect the dock and everything (including ethernet) works fine through the connected dock.

EDIT3: After finding out of what explained in EDIT2 I rebooted and now the docking station works just fine.
As requested by a user who commented my question:

Another thing that I found on the internet is trying to update the firmware of the docking station through my windows partition but the update procedure failed.

Unfortunately, as I said above (in EDIT3), now the docking station is working fine. I booted one more time without doing the trick of disconnecting before the boot and reconnecting it after the boot and it seems working. I will write here if I have more problems which could be helpful for other people.

EDIT4 (ETHERNET STILL NOT WORKING): This is not working anymore. This is the output when I do ifconfig -a while the ethernet cable is connected to the docking station and it is not working.

eth0      Link encap:Ethernet  HWaddr c8:f7:50:0a:4f:20  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:788 errors:0 dropped:0 overruns:0 frame:0
      TX packets:397 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:237207 (237.2 KB)  TX bytes:50493 (50.4 KB)
      Interrupt:16 Memory:91300000-91320000 
wlan0     Link encap:Ethernet  HWaddr 98:3b:8f:e2:d5:0b  
      inet addr:128.179.139.151  Bcast:128.179.143.255  Mask:255.255.248.0
      inet6 addr: fe80::dc48:358d:7100:45b8/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:3718 errors:0 dropped:0 overruns:0 frame:0
      TX packets:4855 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:1971194 (1.9 MB)  TX bytes:949476 (949.4 KB)

Thanks in advance for the help.

Best Answer

  • I use lenovo l390 + ThinkPad hybrid docking station + ubuntu 18.04 (4.15.0-46-generic) and I have the same issues : - Charge is okay - USB ports through the docking station work - neither the screen nor internet work through the docking station

    I guess this problem comes from the version of the kernel. The same kind of issues appeared in 4.15.0-44-generic and has been fixed in 45 version.

    Downgrading the kernel was proposed when this bug appears :

    After most recent kernel update (4.15.0-44-generic) my tablet freezes whenever plugged into docking station

    Ubuntu 18.04.1 LTS issue with Dell Thunderbolt 3 Dock after update

  • Related Question