Ubuntu – FileZilla: The following packages have unmet dependencies

aptdependenciessoftware installation

I am trying to install FileZilla 3.19 but I get this error when running apt-get install filezilla:

Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies.  filezilla : Depends: libdbus-1-3 (>= 1.9.14) but 1.6.18-0ubuntu4.3 is to be installed
             Depends: libfilezilla0 but it is not going to be installed
             Depends: libgnutls30 (>= 3.4.2) but it is not installable
             Depends: libnettle6 but it is not installable
             Depends: libpugixml1v5 (>= 1.7) but it is not installable
             Depends: libstdc++6 (>= 5.2) but 4.8.4-2ubuntu1~14.04.3 is to be installed
             Depends: libwxbase3.0-0v5 (>= 3.0.2+dfsg) but it is not installable
             Depends: libwxgtk3.0-0v5 (>= 3.0.2+dfsg) but it is not installable E: Unable to correct problems, you have held broken packages.

How do I fix this?

Best Answer

  • You have the GetDeb package repository configured to use the Xenial packages even though your other packages are for Trusty. You need to edit the relevant sources.list file and replace xenial with trusty. Here's one automated way to do it and update the package list:

    sudo sed -i -e 's/xenial-getdeb/trusty-getdeb/' /etc/apt/sources.list{,.d/*.list}
    sudo apt-get update
    

    Then run

    apt-cache policy filezilla
    

    to identify the version you want to install. apt-cache lists package versions and their originating source lines. Choose one that has “trusty” in the source line. Now you re-install the filezilla package in the correct version while fixing package problems. Replace <VERSION> according to you findings from the previous step and run:

    sudo apt-get install -f filezilla=<VERSION>