Ubuntu – GIMP will not start, GEGL error

gimp

I get this error,

GEGL version too old!

GIMP requires GEGL version 0.4.16 or later.
Installed GEGL version is 0.4.14.

Somehow you or your software packager managed
to install GIMP with an older GEGL version.

Please upgrade to GEGL version 0.4.16 or later.

I've tried removing and reinstalling GIMP. I've tried removing and reinstalling GEGL. When I do, it appears it is installing 0.4.16. Same error every time. It was working just the other day. Version 2.10

I don't know what to try next.

Best Answer

I had to add the repo again. Then run:

sudo apt install ppa-purge && sudo ppa-purge ppa:otto-kesselgulasch/gimp
sudo apt-get install gimp

After that gimp was able to install and start normally.