Ubuntu – Google Chrome not rendering webpages correctly

12.04google-chromejavascript

I am facing some serious web page rendering issues with Chrome.
It is more prominent during javascript based animations and stuff on websites like youtube.
I have tried removing chrome using (sudo apt-get purge google-chrome-stable) and then reinstalling it. But the problems still persist.
The same webpages work correctly on firefox on ubuntu and chrome on windows. The problem only shows up when I use chrome on ubuntu.

I think the issue has started after I updated to the latest version of Chrome. I have used Chrome previously on this machine without any problems.

I have attached a image that demonstrates the issue.

enter image description here

What could possibly be the problem?

PS: here's the output of lshw -c video:

*-display               
   description: VGA compatible controller
   product: Madison [Radeon HD 5000M Series]
   vendor: Hynix Semiconductor (Hyundai Electronics)
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
   configuration: driver=fglrx_pci latency=0
   resources: irq:46 memory:e0000000-efffffff memory:f0020000-f003ffff ioport:d000(size=256) memory:f0000000-f001ffff

Here's the output of lspci -nn:
output of lspci -nn

Best Answer

  • The issue was with the graphic drivers.

    I downloaded and installed the latest driver from AMD and now everything looks fine.

    Thanks to @tijybba.

  • Related Question