Ubuntu – Google Earth Installation x64 (Xenial) lsb-core

16.04google earthsoftware installation

Google Earth x86 64 bit Architecture Installation Troubleshoot

depends on lsb-core (>= 3.2)

If you had these issues

Package lsb-core is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

after running this

sudo apt-get install lsb-core
[sudo] password for 
Reading package lists... Done
Building dependency tree       
Reading state information... Done

E: Package 'lsb-core' has no installation candidate

Or this

The following packages have unmet dependencies:
 lsb-core : Depends: alien (>= 8.36) but it is not going to be installed

And have tried these resources to no avail.

I have a solution below that worked for me and I hope it works for you.

Best Answer

  • SHORTCUT

    • Make sure you do not have any version of Google Earth on your system

      sudo apt-get purge google-earth-stable

    • Have aptitude installed

      sudo apt-get update && sudo apt-get install aptitude

    Download the latest version of Google Earth
    Select .64 bit deb file and Hit Agree and Download

    Select .64 bit deb file

    • Run

      sudo aptitude -f install lsb-core

    Downgrade your system by hitting 'n', then 'y', 'y

    • see further down for exact details of specific output

    Then run sudo dpkg -i "NAMEOFYOURDEB.deb"

    To install all necessary packages for it. It will tell you if you need to install something else.

    Finally finish installing it by running

    sudo gdebi "name_of_your_current_release".deb 
    

    "only use sudo if not root"

    LONGER EXPLANATION

    Assumptions of what I had installed on my machine and am assuming you have on yours:

    • I had aptitude installed.
    • I did not google-earth on my system. It was completely removed.
    • I downloaded a current stable .deb file on my system

    Only Run Commands Below this Line After Reading Below

    • I then ran sudo dpkg -i google-earth-pro-stable_current_amd64.deb which satisfies all the package dependencies for it.

    • I then ran

      sudo gdebi "name_of_your_current_release".deb

    You should see Google Earth in Menu Bar when you search "google earth"

    ______READ____ME_____FIRST____________

    These are the Steps to follow for downgrading.

    1. I downgraded my system because in order to run google earth they require you to have lib-core and that apparently is not supported anymore so run sudo aptitude -f install lsb-core

    2. Then you would enter No, when first asked and then you would enter Yes.

      • The reason why, you would enter no first is because if you respond 'no', it would simply not change anything and you will still get the 'lsb-core' error

    The following NEW packages will be installed: alien{a} at{a} lib32z1{a} librpmbuild3{a} librpmsign1{a} lsb-core pax{a} rpm{ab} 0 packages upgraded, 8 newly installed, 0 to remove and 1 not upgraded. Need to get 493 kB of archives. After unpacking 1,611 kB will be used. The following packages have unmet dependencies: rpm : Depends: rpm-common (= 4.10.1-2.1ubuntu1) but 4.12.0.1+dfsg1-3build3 is installed. The following actions will resolve these dependencies:

     Keep the following packages at their current version:
     1)alien [Not Installed] 
     2)lsb-core[Not Installed]
     3) rpm [Not Installed]
    

    Accept this solution? [Y/n/q/?] n

    The following actions will resolve these dependencies:

     Downgrade the following packages:                                         1)     rpm-common [4.12.0.1+dfsg1-3build3 (now) -> 4.10.1-2.1ubuntu1
    

    (raring)] 2) rpm2cpio [4.12.0.1+dfsg1-3build3 (now) -> 4.10.1-2.1ubuntu1 (raring)]

    Accept this solution? [Y/n/q/?] y

    The following packages will be DOWNGRADED: rpm-common rpm2cpio The following NEW packages will be installed: alien{a} at{a} lib32z1{a} librpmbuild3{a} librpmsign1{a} lsb-core pax{a} rpm{a} 0 packages upgraded, 8 newly installed, 2 downgraded, 0 to remove and 1 not upgraded. Need to get 523 kB of archives. After unpacking 1,696 kB will be used.

    Do you want to continue? [Y/n/?] y