Ubuntu – “gstreamer1.0-libav” Package dependencies cannot be resolved

14.04codecsgstreamer

I am in Ubuntu 14.04 amd64, I have met all updates available, but also I am getting these errors in media codecs. First I got this error:

    gstreamer1.0-libav:i386: Depends: libavcodec-extra-54 (>= 6:9.13) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libavformat54 (>= 6:9.1-1) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libavutil52 (>= 6:9.1-1) but 6:9.16-0ubuntu0.14.04.1+fdkaac is to be installed
                 Depends: libc6 (>= 2.7) but 2.19-0ubuntu6.3 is to be installed
                 Depends: libglib2.0-0 (>= 2.37.3) but 2.40.0-2 is to be installed

After getting this error I tried to install those libraries, i then did

    sudo apt-get install libavcodec-extra-54

That went good, and i could download that package. But any other packages were not installed, terminal said they were already installed.

But again I am getting this error.

    The following packages have unmet dependencies:
   libavcodec54: 

Best Answer

  • You can try the following:

    sudo apt-get install libopus0

    Then:

    sudo apt-get install gstreamer1.0-liba

    According to this it should work. It did for him.

    Unfortunately I do not find any reason why it works or why libavcodec54 do not.

    Reference

    1. ubuntu 14.04 problem with gstreamer1.0-libav
  • Related Question