Ubuntu – Gvfsd-smb-browse causes 100% CPU usage

gvfssamba

After upgraded to 16.04, gvfsd-smb-browse always causes 100% CPU usage. This situation seems related a bug : https://bugzilla.redhat.com/show_bug.cgi?id=1303300. But maybe not related it.How can I solve this problem? Thanks very much.

Best Answer

I am currently having the same problem. My solution was to kill gvfsd-smb-browse with the command kill n where n is an integer for its process id. You can see it by running the top command on a terminal.

I am not sure if this will work on all systems. In my case I have a dual boot setup (Win7 and Ubuntu 16.04.1) on my Laptop. The bug, started happening recently (maybe after upgrades moved me from 16.04 to 16.04.1, not really sure) and it happens when I try to access/mount NTFS volumes for the first time after logging in. (I have left them as NTFS so I can also access them from Windows).

After I kill the process nothing bad happens and I can still access the volumes normally. Depending on your problem you might also be ok with killing it and continuing using your computer.

Another potential solution is the one provided with this answer. You may want to try that as well to see if it solves your problem without creating other problems.

There are several bugs submitted around this, for example 1 and 2 but they appear to be unassigned for some reason. (Note: I am uncertain if they are the same as my case and if I should comment on them or start a new one or do something else to help developers with solving it.)

update: I have stopped getting this bug lately. This seems to be because I am connecting to a different wi-fi network for Internet.