Ubuntu – Hardrive won’t mount on 12.10

hard drive

I just upgraded to 12.10 and one of my media hard drives won't mount. The drive shows up on /dev/sda but doesn't mount. dmesg|tail

[  289.496933] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  292.502310] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  299.540914] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  307.700473] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  307.804819] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  698.017043] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  703.933411] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  704.055936] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[  706.293292] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value
[ 1134.268187] FAT-fs (sda1): Unrecognized mount option "x-gvfs-show" or missing value

Best Answer

  • Since this bug still exists in Ubuntu 14.04 LTS, I post the following solution that I actually found on the link you posted in your last comment :

    try comment=x-gvfs-show instead of comment=gvfs-show (instead of x-gvfs-show)

    For people using Disks utility, just uncheck "Show in user interface" in the Mount Options of the partition, and then add comment=x-gvfs-show in the list of options below Symbolic Icon Name :

    enter image description here

    This should fix the issue.

  • Related Question