Ubuntu – How install postgresql 9.4

postgresql

After trying apt-get install postgresql-9.4, updating, trying again etc etc. It seems I can't install it:

 Couldn't find any package by regex 'postgresql-9.4'

I know there is a similar question in askubuntu but the answer there doesn't work either.

I need postgresql version 9.4 cause I'm doing a pg:backup from Heroku and I get this error if I don't have 9.4.

Thanks a lot for your help.

Best Answer

  • This command installs the recent version for your distribution:

    sudo apt-get install postgresql
    

    postgresql-9.4 is available since Utopic.

    Source

    Here is a step by step guide to install Postgesql 9.4 for your Ubuntu (Utopic, Trusty, Precise, Lucid) version.

    sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt YOUR_UBUNTU_VERSION_HERE-pgdg main" 
    

    For trusty:

    sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"
    

    To get your ubuntu version:

    lsb_release -sc
    

    Now import the public key and install:

    wget --quiet -O - https://postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - 
    sudo apt-get update
    sudo apt-get install postgresql-9.4