Ubuntu – How to download a .deb package

deblibreofficesoftware installation

This server has a .deb package that I want to download. The issue is, it only lets me download one file at a time from within the package. How can I download just the .deb file to install?

Best Answer

The deb file has been compressed, I downloaded and extracted the largest archive as follows:

wget http://downloadarchive.documentfoundation.org/libreoffice/old/3.5.7.2/deb/x86_64/LibO_3.5.7rc2_Linux_x86-64_install-deb_en-US.tar.gz
tar xvf LibO_3.5.7rc2_Linux_x86-64_install-deb_en-US.tar.gz

This extraction creates a directory structure:

LibO_3.5.7rc2_Linux_x86-64_install-deb_en-US/DEBS

and all of the deb packages are in this 'DEBS' folder:

andrew@corinth:~/LibO_3.5.7rc2_Linux_x86-64_install-deb_en-US/DEBS$ ls
desktop-integration
libobasis3.5-base_3.5.7-2_amd64.deb
libobasis3.5-binfilter_3.5.7-2_amd64.deb
libobasis3.5-calc_3.5.7-2_amd64.deb
libobasis3.5-core01_3.5.7-2_amd64.deb
libobasis3.5-core02_3.5.7-2_amd64.deb
libobasis3.5-core03_3.5.7-2_amd64.deb
libobasis3.5-core04_3.5.7-2_amd64.deb
libobasis3.5-core05_3.5.7-2_amd64.deb
libobasis3.5-core06_3.5.7-2_amd64.deb
libobasis3.5-core07_3.5.7-2_amd64.deb
libobasis3.5-draw_3.5.7-2_amd64.deb
libobasis3.5-en-us_3.5.7-2_amd64.deb
libobasis3.5-en-us-base_3.5.7-2_amd64.deb
libobasis3.5-en-us-calc_3.5.7-2_amd64.deb
libobasis3.5-en-us-math_3.5.7-2_amd64.deb
libobasis3.5-en-us-res_3.5.7-2_amd64.deb
libobasis3.5-en-us-writer_3.5.7-2_amd64.deb
libobasis3.5-extension-beanshell-script-provider_3.5.7-2_amd64.deb
libobasis3.5-extension-javascript-script-provider_3.5.7-2_amd64.deb
libobasis3.5-extension-mediawiki-publisher_3.5.7-2_amd64.deb
libobasis3.5-extension-nlpsolver_3.5.7-2_amd64.deb
libobasis3.5-extension-pdf-import_3.5.7-2_amd64.deb
libobasis3.5-extension-presentation-minimizer_3.5.7-2_amd64.deb
libobasis3.5-extension-presenter-screen_3.5.7-2_amd64.deb
libobasis3.5-extension-python-script-provider_3.5.7-2_amd64.deb
libobasis3.5-extension-report-builder_3.5.7-2_amd64.deb
libobasis3.5-gnome-integration_3.5.7-2_amd64.deb
libobasis3.5-graphicfilter_3.5.7-2_amd64.deb
libobasis3.5-images_3.5.7-2_amd64.deb
libobasis3.5-impress_3.5.7-2_amd64.deb
libobasis3.5-javafilter_3.5.7-2_amd64.deb
libobasis3.5-kde-integration_3.5.7-2_amd64.deb
libobasis3.5-math_3.5.7-2_amd64.deb
libobasis3.5-ogltrans_3.5.7-2_amd64.deb
libobasis3.5-onlineupdate_3.5.7-2_amd64.deb
libobasis3.5-ooofonts_3.5.7-2_amd64.deb
libobasis3.5-ooolinguistic_3.5.7-2_amd64.deb
libobasis3.5-postgresql-sdbc_3.5.7-2_amd64.deb
libobasis3.5-pyuno_3.5.7-2_amd64.deb
libobasis3.5-writer_3.5.7-2_amd64.deb
libobasis3.5-xsltfilter_3.5.7-2_amd64.deb
libreoffice3.5_3.5.7-2_amd64.deb
libreoffice3.5-base_3.5.7-2_amd64.deb
libreoffice3.5-calc_3.5.7-2_amd64.deb
libreoffice3.5-dict-en_3.5.7-2_amd64.deb
libreoffice3.5-dict-es_3.5.7-2_amd64.deb
libreoffice3.5-dict-fr_3.5.7-2_amd64.deb
libreoffice3.5-draw_3.5.7-2_amd64.deb
libreoffice3.5-en-us_3.5.7-2_amd64.deb
libreoffice3.5-impress_3.5.7-2_amd64.deb
libreoffice3.5-math_3.5.7-2_amd64.deb
libreoffice3.5-stdlibs_3.5.7-2_amd64.deb
libreoffice3.5-ure_3.5.7-2_amd64.deb
libreoffice3.5-writer_3.5.7-2_amd64.deb
andrew@corinth:~/LibO_3.5.7rc2_Linux_x86-64_install-deb_en-US/DEBS$ 

And then if you wish you can install all of these from within the DEBS directory by running:

sudo dpkg -i *.deb

Installing any of these could be an issue depending on:

  1. Which version of Ubuntu you are using
  2. Which particular deb package you are trying to install

Dependencies being the main issue as well as more modern versions being already available / installed from the Ubuntu repository...