Ubuntu – How to fix dependency problems in Ubuntu 16.04

16.04dependencies

I'm trying to install Ring and have run into dependency problems. I have no idea how to fix this. Would you have any ideas about how to approach this problem? I have attempted sudo apt-get update, sudo apt-get autoremove and sudo apt-get -f install but nothing seemed to help.

>sudo apt-get install ring-gnome
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ring-gnome : Depends: libebook-1.2-16 (>= 3.17) but 3.16.5-1ubuntu3 is to be installed
              Depends: libebook-contacts-1.2-2 (>= 3.16.2) but it is not installable
              Depends: libedataserver-1.2-21 (>= 3.17) but it is not installable
              Depends: libqt5core5a (>= 5.5.1) but 5.4.2+dfsg-2ubuntu9 is to be installed
              Depends: ring-daemon but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Best Answer

Open the terminal and type the following commands:

sudo apt-get install aptitude
sudo aptitude -f install ring-gnome

Read the output and confirm then choose Downgrade package.