Ubuntu – How to install Flash player on Ubuntu

browserflashgamespepperflashplugins

Even though I have the latest Adobe Flash player 11.2 for Linux in Firefox –
ref: Flash player security doubts – a particular online flash game still requests that I update to the latest flash player.

I've tried this online game on my laptop (Windows 8 with Flash Player 11.8) and it has no problems.

Is there a way to trick Ubuntu or this game into thinking Flash Player 11.8 is "installed"?

Best Answer

  • Note: This answer is severely outdated. Please refer to karel’s answer instead which describes how Canonical and Adobe currently recommend to install Flash Player in Ubuntu.


    For Linux, the latest version of Adobe Flash Player is 11.2 which you already have. Sorry, but it cannot be updated to 11.8. Adobe provides security backports to Flash Player 11.2 for Linux.

    To install the Flash plug-in on Ubuntu 13.04 (Raring Ringtail), please follow this process:

    1. Enable the multiverse repository, as shown here: How do I enable the "multiverse" repository?

    2. Open a terminal window (press Ctrl+Alt+T) and copy/paste this line:

      sudo apt-get install flashplugin-installer 
      
    3. When the Flash Player is installed, close the terminal window and restart your browser.